Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365189 - VDC guest subscriptions showing as null in activation key
Summary: VDC guest subscriptions showing as null in activation key
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: 6.2
Assignee: Justin Sherrill
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: CEE_Sat6_Top_BZs, GSS_Sat6_Top_Bugs 1397542 1405534
TreeView+ depends on / blocked
 
Reported: 2016-08-08 14:54 UTC by John Mitsch
Modified: 2018-12-06 20:49 UTC (History)
19 users (show)

Fixed In Version: rubygem-katello-3.0.0.80
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1397542 (view as bug list)
Environment:
Last Closed: 2016-10-04 06:44:26 UTC


Attachments (Terms of Use)
add subs (deleted)
2016-09-28 19:47 UTC, jcallaha
no flags Details
added subs (deleted)
2016-09-28 19:48 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2594971 None None None 2016-10-04 22:19:02 UTC
Red Hat Product Errata RHBA-2016:1993 normal SHIPPED_LIVE Satellite 6.2.2 Async Bug Release 2016-10-04 10:43:20 UTC
Foreman Issue Tracker 16398 None None None 2016-08-31 18:00:26 UTC

Description John Mitsch 2016-08-08 14:54:50 UTC
Creating a new bug from https://bugzilla.redhat.com/show_bug.cgi?id=1362194

Description of problem:
A guest subscription from a VDC subscription shows as 'null' in activation key

Version-Release number of selected component (if applicable):
6.2.0

How reproducible:
Difficult 

Steps to Reproduce:
1.Set up virt-who
2.Attach VDC subscription to host
3.Try to attach guest subscription to activation key

Actual results:
sub name is 'null'

Expected results:
sub name shows

Additional info:
More info in https://bugzilla.redhat.com/show_bug.cgi?id=1362194

Comment 5 John Mitsch 2016-08-29 13:49:41 UTC
Michal,

I am currently working on this bug, I don't have a good eta, but this should be a workaround:

# foreman-rake console
> Katello::Subscription.import_all
> Katello::Pool.import_all

-John

Comment 6 Calvin Hartwell 2016-08-31 10:06:00 UTC
(In reply to John Mitsch from comment #5)
> Michal,
> 
> I am currently working on this bug, I don't have a good eta, but this should
> be a workaround:
> 
> # foreman-rake console
> > Katello::Subscription.import_all
> > Katello::Pool.import_all
> 
> -John

@John do I have to do that every time I register a new host?!

Comment 8 Justin Sherrill 2016-08-31 17:39:50 UTC
Connecting redmine issue http://projects.theforeman.org/issues/16398 from this bug

Comment 9 Bryan Kearney 2016-08-31 20:22:10 UTC
Upstream bug component is Candlepin

Comment 13 Bryan Kearney 2016-09-06 18:18:13 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/16398 has been resolved.

Comment 16 jcallaha 2016-09-28 19:46:11 UTC
Verified in Satellite 6.2.2 Async Snap 1

VDC guest subscriptions now work as expected. See attached screenshots for verification.

Comment 17 jcallaha 2016-09-28 19:47:41 UTC
Created attachment 1205643 [details]
add subs

Comment 18 jcallaha 2016-09-28 19:48:19 UTC
Created attachment 1205644 [details]
added subs

Comment 20 errata-xmlrpc 2016-10-04 06:44:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1993


Note You need to log in before you can comment on or make changes to this bug.