Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365177 - imgbase LVM operations fail if an error appears
Summary: imgbase LVM operations fail if an error appears
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: General
Version: 4.0
Hardware: Unspecified
OS: Unspecified
urgent
high vote
Target Milestone: ovirt-4.0.2
: 4.0
Assignee: Fabian Deutsch
QA Contact: Tareq Alayan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 14:25 UTC by Tareq Alayan
Modified: 2016-08-17 14:44 UTC (History)
2 users (show)

Fixed In Version: imgbased-0.8.0-0.1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-17 14:44:40 UTC
oVirt Team: Node
rule-engine: ovirt-4.0.z+
rule-engine: blocker+
rule-engine: planning_ack+
fdeutsch: devel_ack+
talayan: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 62077 master MERGED Revert "utils: grab stderr as part of call()" 2016-08-09 10:44:10 UTC
oVirt gerrit 62078 master MERGED utils: Cleanup some calls 2016-08-09 10:47:43 UTC

Description Tareq Alayan 2016-08-08 14:25:52 UTC
Description of problem:
imgbase check will report Status Failed in case there are some lvs lvm warnings 


Version-Release number of selected component (if applicable):
imgbased-0.7.4-0.1.el7ev.noarch
rhvh-4.0-0.20160803.0

How reproducible:
always when there are FC luns mapped to host. 

Steps to Reproduce:

1. 
imgbase check

Actual results:
Status: FAILED
Mount points ... OK
  Separate /var ... OK
  Discard is used ... OK
Basic storage ... OK
  Initialized VG ... OK
  Initialized Thin Pool ... OK
  Initialized LVs ... OK
Thin storage ... FAILED - It looks like the LVM layout is not correct. The reason could be an incorrect installation.
  Checking from thin metadata ... ERROR
    Exception in '<function <lambda> at 0x28cf1b8>': AssertionError() 


Expected results:
Status: OK
Mount points ... OK
  Separate /var ... OK
  Discard is used ... OK
Basic storage ... OK
  Initialized VG ... OK
  Initialized Thin Pool ... OK
  Initialized LVs ... OK
Thin storage ... OK
  Checking available space in thinpool ... OK
  Checking thinpool auto-extend ... OK

Additional info:

Comment 1 Fabian Deutsch 2016-08-08 15:00:30 UTC
This is a regression of the work done for enable rollbacks which landed late.

It can affect all of the imgbase functionality.

Comment 2 Red Hat Bugzilla Rules Engine 2016-08-08 15:03:56 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Tareq Alayan 2016-08-17 09:24:56 UTC
verified on 
imgbased-0.8.4-1.el7ev.noarch
rhvh-4.0-0.20160811.0+1

imgbase check
  Found duplicate PV 8vVruG9Eaerqj34JhyScPyLjgScqdNJT: using /dev/sde not /dev/sdk
  Using duplicate PV /dev/sde which is last seen, replacing /dev/sdk
  Found duplicate PV 8vVruG9Eaerqj34JhyScPyLjgScqdNJT: using /dev/sdw not /dev/sde
  Using duplicate PV /dev/sdw which is last seen, replacing /dev/sde
  Found duplicate PV 8vVruG9Eaerqj34JhyScPyLjgScqdNJT: using /dev/sdw not /dev/sdq
  Using duplicate PV /dev/sdw without holders, ignoring /dev/sdq
Status: OK
Mount points ... OK
  Separate /var ... OK
  Discard is used ... OK
Basic storage ... OK
  Initialized VG ... OK
  Initialized Thin Pool ... OK
  Initialized LVs ... OK
Thin storage ... OK
  Checking available space in thinpool ... OK
  Checking thinpool auto-extend ... OK


Note You need to log in before you can comment on or make changes to this bug.