Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365124 - dump -0.4-0.28 crashes with a SEGV after writing 1 10K block to dumpfile
Summary: dump -0.4-0.28 crashes with a SEGV after writing 1 10K block to dumpfile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dump
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Josef Ridky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1366864 1367385 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 13:07 UTC by Valdis Kletnieks
Modified: 2016-10-28 00:40 UTC (History)
5 users (show)

Fixed In Version: dump-0.4-0.29.b45.fc24 dump-0.4-0.30.b46.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-28 00:40:00 UTC


Attachments (Terms of Use)

Description Valdis Kletnieks 2016-08-08 13:07:06 UTC
Description of problem:

Dump crashes when it starts trying to dump the data - it writes one block and dies.

GDB says:

(gdb) run -0 -z3 -u -f /disk2/backups/zz9.dump -L / /
Starting program: /usr/sbin/dump -0 -z3 -u -f /disk2/backups/zz9.dump -L / /
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
  DUMP: Date of this level 0 dump: Mon Aug  8 08:51:13 2016
  DUMP: Dumping /dev/mapper/turing--police-root (/) to /disk2/backups/zz9.dump
  DUMP: Label: /
  DUMP: Writing 10 Kilobyte records
  DUMP: Compressing output at transformation level 3 (zlib)
  DUMP: mapping (Pass I) [regular files]
  DUMP: mapping (Pass II) [directories]
  DUMP: estimated 159656 blocks.
Detaching after fork from child process 76592.
  DUMP: Volume 1 started with block 1 at: Mon Aug  8 08:51:14 2016
  DUMP: dumping (Pass III) [directories]
  DUMP: SIGSEGV: ABORTING!
  DUMP: SIGSEGV: ABORTING!
  DUMP: SIGSEGV: ABORTING!
  DUMP: SIGSEGV: ABORTING!

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7040450 in __libc_wait (stat_loc=stat_loc@entry=0x7fffffffb178) at ../sysdeps/unix/sysv/linux/wait.c:29
29        pid_t result = SYSCALL_CANCEL (wait4, WAIT_ANY, stat_loc, 0,
Missing separate debuginfos, use: dnf debuginfo-install bzip2-libs-1.0.6-20.fc24.x86_64 e2fsprogs-libs-1.43.1-2.fc25.x86_64 libcom_err-1.43.1-2.fc25.x86_64 lzo-2.08-8.fc24.x86_64 zlib-1.2.8-10.fc24.x86_64
(gdb) where
#0  0x00007ffff7040450 in __libc_wait (stat_loc=stat_loc@entry=0x7fffffffb178) at ../sysdeps/unix/sysv/linux/wait.c:29
#1  0x000055555555c568 in startnewtape (top=1) at tape.c:813
#2  0x0000555555558116 in main (argc=<optimized out>, argv=0x7fffffffe570) at main.c:930

zz9.dump has exactly 1 10K (default size) block:

ls -l /disk2/backups/zz9.dump 
-rw-r--r--. 1 root root 10240 Aug  8 08:51 /disk2/backups/zz9.dump

dump-0.4-0.27.b44.fc24.x86_64 works just fine...


Version-Release number of selected component (if applicable):
dump-0.4-0.28.b45.fc26.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Update System 2016-08-11 10:47:31 UTC
dump-0.4-0.29.b45.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-83a3339530

Comment 2 Fedora Update System 2016-08-11 10:47:46 UTC
dump-0.4-0.29.b45.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a344486d48

Comment 3 Valdis Kletnieks 2016-08-11 16:12:23 UTC
Pulled dump-0.4-0.29.b45.fc26.x86_64 down from koji, confirming that it works OK, thanks for the quick fix....

Comment 4 Fedora Update System 2016-08-11 16:56:05 UTC
dump-0.4-0.29.b45.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a344486d48

Comment 5 Fedora Update System 2016-08-12 03:02:53 UTC
dump-0.4-0.29.b45.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-83a3339530

Comment 6 Josef Ridky 2016-08-15 08:11:19 UTC
*** Bug 1366864 has been marked as a duplicate of this bug. ***

Comment 7 Josef Ridky 2016-08-16 10:33:59 UTC
*** Bug 1367385 has been marked as a duplicate of this bug. ***

Comment 8 Jason Tibbitts 2016-09-01 16:42:34 UTC
So I'm running Fedora 24 with dump-0.4-0.29.b45.fc24.x86_64 (which I believe according to comment 1 means that I should have the fix for this).  But I'm still seeing segfaults:

# /sbin/dump -v -0 -s 1048576 -f - /dev/mapper/vg0-var > /dev/null
  DUMP: Date of this level 0 dump: Thu Sep  1 10:22:49 2016
  DUMP: Dumping /dev/mapper/vg0-var (/var) to standard output
  DUMP: Excluding inode 8 (journal inode) from dump
  DUMP: Excluding inode 7 (resize inode) from dump
  DUMP: Label: none
  DUMP: Writing 10 Kilobyte records
  DUMP: mapping (Pass I) [regular files]
  DUMP: mapping (Pass II) [directories]
  DUMP: estimated 2807705 blocks.
  DUMP: Volume 1 started with block 1 at: Thu Sep  1 10:22:49 2016
  DUMP:   DUMP: SIGSEGV: ABORTING!
  DUMP:   DUMP: SIGSEGV: ABORTING!
SIGSEGV: ABORTING!
Segmentation fault (core dumped)
[root@rsync2 tmp]#   DUMP: Broken pipe
  DUMP: The ENTIRE dump is aborted.

I get some number of core files, usually three.  Here are the backtraces for each.

#0  0x00007faa65dca5be in __libc_wait (stat_loc=stat_loc@entry=0x7ffcfb53ced8) at ../sysdeps/unix/sysv/linux/wait.c:29
#1  0x00005632d4411588 in startnewtape (top=1) at tape.c:813
#2  0x00005632d440d136 in main (argc=<optimized out>, argv=0x7ffcfb5402c8) at main.c:930


#0  0x00007f84a760c02e in __read_nocancel () at ../sysdeps/unix/syscall-template.S:84
#1  0x000055fce07ce51e in read (__nbytes=16, __buf=0x7ffe07b08740, __fd=8) at /usr/include/bits/unistd.h:44
#2  dump_atomic_read (fd=8, buf=buf@entry=0x7ffe07b08740 "", count=count@entry=16) at tape.c:1351
#3  0x000055fce07cff1e in flushtape () at tape.c:418
#4  0x000055fce07d0496 in writerec (dp=dp@entry=0x55fce0c7c1a0, isspcl=isspcl@entry=0) at tape.c:253
#5  0x000055fce07d0f95 in dumpmap (map=<optimized out>, type=<optimized out>, ino=<optimized out>) at traverse.c:1310
#6  0x000055fce07cb159 in main (argc=<optimized out>, argv=0x7ffe07b0ba18) at main.c:932


#0  0x0000000000000000 in ?? ()
#1  0x000055fce07cea6b in doslave (cmd=5, first=<optimized out>) at tape.c:1329
#2  0x000055fce07cf664 in enslave () at tape.c:1047
#3  startnewtape (top=1) at tape.c:908
#4  0x000055fce07cb136 in main (argc=<optimized out>, argv=0x7ffe07b0ba18) at main.c:930

Comment 9 Jason Tibbitts 2016-09-01 16:44:43 UTC
Never mind, somehow I got the crash on one machine but ran rpm -q on another. I pulled the update from testing onto the problem machine and everything works fine now.

Sorry for the trouble.

Comment 10 Fedora Update System 2016-09-02 20:54:03 UTC
dump-0.4-0.29.b45.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-09-15 13:09:11 UTC
dump-0.4-0.30.b46.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-efe4ccf884

Comment 12 Fedora Update System 2016-09-16 01:24:19 UTC
dump-0.4-0.30.b46.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-efe4ccf884

Comment 13 Fedora Update System 2016-10-28 00:40:00 UTC
dump-0.4-0.30.b46.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.