Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365069 - point user to use `ipa-replica-manage disconnect` when using `del` for removing winsync agreement
Summary: point user to use `ipa-replica-manage disconnect` when using `del` for removi...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 12:11 UTC by Sudhir Menon
Modified: 2018-10-19 12:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-10-19 12:02:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
messages file (deleted)
2016-08-08 12:11 UTC, Sudhir Menon
no flags Details
Attaching dirsrv error logs. (deleted)
2016-08-08 12:14 UTC, Sudhir Menon
no flags Details

Description Sudhir Menon 2016-08-08 12:11:10 UTC
Created attachment 1188679 [details]
messages file

Description of problem: ipa-replica-manage del <$ADHost> fails to delete replication agreement.

Version-Release number of selected component (if applicable):
ipa-server-dns-4.4.0-5.el7.noarch
ipa-server-common-4.4.0-5.el7.noarch
ipa-server-trust-ad-4.4.0-5.el7.x86_64
ipa-server-4.4.0-5.el7.x86_64
389-ds-base-1.3.5.10-5.el7.x86_64

How reproducible: Always


Steps to Reproduce:
1. Establish winsync agreement with windows AD
2. Now try to delete the agreement with the below command.

ipa-replica-manage del <$ADHostname>

Actual results:
1. [root@vm92 ipa-winsync]# ipa-replica-manage del apache.pne.qe
apache.pne.qe: server not found
Where apache.pne.qe is the test windows AD

2. Attaching the /var/log/messages file output.


Expected results: 
The replication agreement should be deleted when the command is issued, instead it gives the message server not found.

Additional info:
1. IPA-Server and windows AD are in the same timezone and have time in sync.
2. The firewall is not running on IPA/Windows AD
3. The dig command for SRV record for windows domain is resolvable.

Comment 1 Sudhir Menon 2016-08-08 12:14:38 UTC
Created attachment 1188686 [details]
Attaching dirsrv error logs.

Comment 4 Petr Vobornik 2016-08-09 12:25:08 UTC
I believe the right command for removing winsync replication is:

  ipa-replica-manage disconnect windows.ad.example.com


` ipa-replica-manage del` is for removing IPA masters

As is written in man page:

"""
       Create a winsync replication agreement:

               # ipa-replica-manage connect --winsync --passsync=MySecret --cacert=/root/WIN-CA.cer --binddn "cn=administrator,cn=users,dc=ad,dc=example,dc=com" --bindpw MySecret -v windows.ad.example.com

       Remove a winsync replication agreement:
               # ipa-replica-manage disconnect windows.ad.example.com

"""

Comment 5 Petr Vobornik 2016-08-16 11:30:39 UTC
I'm removing regression and test blocker keywords because they are not - see comment 4.

Per triage on Aug 16, we might want to detect this situation and advise to use the proper command. This is a subject for future FreeIPA release -> postponing to later release.

Comment 6 Petr Vobornik 2016-08-17 16:55:15 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6227

Comment 7 Petr Vobornik 2016-10-04 13:25:26 UTC
this is not a issue, see comments 5 and 6

Comment 10 Florence Blanc-Renaud 2018-10-19 12:02:19 UTC
As this is not an issue (see comments 4 and 5) and we want to promote AD trusts instead of investing in winsync, closing as won't fix.


Note You need to log in before you can comment on or make changes to this bug.