Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1365033 - man pages - glibc bits crept in on the top of man pages
Summary: man pages - glibc bits crept in on the top of man pages
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: freeipmi
Version: 7.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Josef Ridky
QA Contact: Rachel Sibley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 11:52 UTC by lejeczek
Modified: 2017-08-29 08:34 UTC (History)
3 users (show)

Fixed In Version: freeipmi-1.5.7-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-29 08:34:19 UTC


Attachments (Terms of Use)
fix manpage issue (deleted)
2016-11-09 08:13 UTC, Josef Ridky
no flags Details | Diff

Description lejeczek 2016-08-08 11:52:08 UTC
Description of problem:


Version-Release number of selected component (if applicable):

freeipmi-1.2.9-7.el7.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Boris Ranto 2016-08-09 08:55:27 UTC
This sounds like some utility have scrambled your terminal settings. The 'reset' command should reset these. If you can see the bits even after you have run these, then please be more specific -- which man page? what command? Do you have a screenshot? ...

Comment 3 lejeczek 2016-08-09 17:33:38 UTC
really.. anything from freeimpi rpm.
example:

/* Copyright (C) 1991‐2012 Free Software Foundation, Inc.
   This file is part of the GNU C Library.

   The  GNU  C  Library is free software; you can redistribute it
and/or
   modify it under the terms of the GNU Lesser General Public
   License as published by the Free Software Foundation; either
   version 2.1 of the License, or (at your option) any later ver‐
sion.

   The  GNU  C Library is distributed in the hope that it will be
useful,
   but WITHOUT ANY WARRANTY; without even the implied warranty of
   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See  the
GNU
   Lesser General Public License for more details.

   You should have received a copy of the GNU Lesser General Pub‐
lic
   License along with the GNU C Library; if not, see
   <http://www.gnu.org/licenses/>.  */ /* This header is separate
from features.h so that the compiler can
   include  it  implicitly at the start of every compilation.  It
must
   not itself include <features.h> or any other header  that  in‐
cludes
   <features.h>  because  the  implicit  include comes before any/* Copyright (C) 1991‐2012 Free Software Foundation, Inc.
   This file is part of the GNU C Library.

   The  GNU  C  Library is free software; you can redistribute it
and/or
   modify it under the terms of the GNU Lesser General Public
   License as published by the Free Software Foundation; either
   version 2.1 of the License, or (at your option) any later ver‐
sion.

   The  GNU  C Library is distributed in the hope that it will be
useful,
   but WITHOUT ANY WARRANTY; without even the implied warranty of
   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See  the
GNU
   Lesser General Public License for more details.

   You should have received a copy of the GNU Lesser General Pub‐
lic
   License along with the GNU C Library; if not, see
   <http://www.gnu.org/licenses/>.  */ /* This header is separate
from features.h so that the compiler can
   include  it  implicitly at the start of every compilation.  It
must/* Copyright (C) 1991‐2012 Free Software Foundation, Inc.
   This file is part of the GNU C Library.

   The  GNU  C  Library is free software; you can redistribute it
and/or
   modify it under the terms of the GNU Lesser General Public
   License as published by the Free Software Foundation; either
   version 2.1 of the License, or (at your option) any later ver‐
sion.

   The  GNU  C Library is distributed in the hope that it will be
useful,
   but WITHOUT ANY WARRANTY; without even the implied warranty of
   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See  the
GNU
   Lesser General Public License for more details.

   You should have received a copy of the GNU Lesser General Pub‐
lic
   License along with the GNU C Library; if not, see
   <http://www.gnu.org/licenses/>.  */ /* This header is separate
from features.h so that the compiler can
   include  it  implicitly at the start of every compilation.  It
must
   not itself include <features.h> or any other header  that  in‐
cludes
   <features.h>  because  the  implicit  include comes before any
feature
   test macros that may be defined in a  source  file  before  it
first
   explicitly  includes  a  system header.  GCC knows the name of
this
   header in order to preinclude it.  */ /* We do support the IEC
559  math  functionality,  real  and complex.  */ /* wchar_t uses
ISO/IEC 10646 (2nd ed., published 2011‐03‐15) /
IPMI-OEM(8)                                        System Commands                                       IPMI-OEM(8)

   Unicode 6.0.  */ /* We do not support C11 <threads.h>.  */

NAME
       ipmi-oem - IPMI OEM utility

SYNOPSIS
       ipmi-oem [OPTION...] <OEMID> <OEMCOMMAND> [OEMOPTION...]

   not itself include <features.h> or any other header  that  in‐
cludes
   <features.h>  because  the  implicit  include comes before any
feature
   test macros that may be defined in a  source  file  before  it
first
   explicitly  includes  a  system header.  GCC knows the name of
this
   header in order to preinclude it.  */ /* We do support the IEC
559  math  functionality,  real  and complex.  */ /* wchar_t uses
ISO/IEC 10646 (2nd ed., published 2011‐03‐15) /
IPMI-OEM(8)                                        System Commands                                       IPMI-OEM(8)

   Unicode 6.0.  */ /* We do not support C11 <threads.h>.  */

NAME
       ipmi-oem - IPMI OEM utility

SYNOPSIS
       ipmi-oem [OPTION...] <OEMID> <OEMCOMMAND> [OEMOPTION...]

feature
   test macros that may be defined in a  source  file  before  it
first
   explicitly  includes  a  system header.  GCC knows the name of
this
   header in order to preinclude it.  */ /* We do support the IEC
559  math  functionality,  real  and complex.  */ /* wchar_t uses
ISO/IEC 10646 (2nd ed., published 2011‐03‐15) /
IPMI-OEM(8)                                        System Commands                                       IPMI-OEM(8)

   Unicode 6.0.  */ /* We do not support C11 <threads.h>.  */

NAME
       ipmi-oem - IPMI OEM utility

SYNOPSIS
       ipmi-oem [OPTION...] <OEMID> <OEMCOMMAND> [OEMOPTION...]

Comment 4 Josef Ridky 2016-11-09 08:13:05 UTC
Created attachment 1218842 [details]
fix manpage issue

This patch should solve described issue.

Comment 8 Josef Ridky 2017-07-10 07:58:41 UTC
This issue has been fixed in upstream version 1.5.6.

Comment 9 Josef Ridky 2017-08-29 08:34:19 UTC
This issue has been fixed for next RHEL release RHEL-7.5. 

Due this issue has not been raised through the regular Red Hat support channels and do not have any assigned customer ticket, I am closing it as NEXTRELEASE.

Feel free to reopen this issue in case, you want to fix it for RHEL-7.4. Please provide business justification in such case.


Note You need to log in before you can comment on or make changes to this bug.