Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364983 - WARNING in cpufreq.c on wake-up after suspend
Summary: WARNING in cpufreq.c on wake-up after suspend
Keywords:
Status: CLOSED DUPLICATE of bug 1360705
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 23
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 10:20 UTC by Laurentiu Pancescu
Modified: 2016-08-09 11:33 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 11:33:56 UTC


Attachments (Terms of Use)
Just the kernel WARNING traces for one wake-up (deleted)
2016-08-08 10:20 UTC, Laurentiu Pancescu
no flags Details
dmesg output after fresh boot, suspend and wake-up (deleted)
2016-08-08 10:22 UTC, Laurentiu Pancescu
no flags Details
Output of lspci -nn (deleted)
2016-08-08 10:24 UTC, Laurentiu Pancescu
no flags Details
/proc/cpuinfo (deleted)
2016-08-08 10:25 UTC, Laurentiu Pancescu
no flags Details

Description Laurentiu Pancescu 2016-08-08 10:20:59 UTC
Created attachment 1188600 [details]
Just the kernel WARNING traces for one wake-up

Description of problem:
I'm getting a kernel WARNING for each CPU, every time my netbook wakes from suspend.  ABRT refuses to file a bug because it wrongly detects the kernel as tainted, after the warning produced by the first CPU.  Please see the attached warning.txt or dmesg.txt.  I'm using tuned with the powersave profile (USB autosuspend enabled), but it is also reproducible with the balanced profile.


Version-Release number of selected component (if applicable):
kernel-4.6.4-201.fc23.x86_64

How reproducible:
It happens every time the system wakes up with kernel 4.6.4.  I cannot reproduce it at all with kernel-4.5.7-202.fc23.x86_64 despite numerous attempts.

Steps to Reproduce:
1. Reboot the system for a clean state
2. Use Fn-F1 to trigger a suspend, or wait some minutes until the system sleeps.
3. Press the space bar to wake it up.

Actual results:
Each wake-up produces two WARNING traces, one for each CPU (single-core Atom processor with hyperthreading).

Expected results:
No WARNING messages from the kernel on wake-up, just like with 4.5.7.

Additional info:

Comment 1 Laurentiu Pancescu 2016-08-08 10:22:38 UTC
Created attachment 1188601 [details]
dmesg output after fresh boot, suspend and wake-up

Comment 2 Laurentiu Pancescu 2016-08-08 10:24:02 UTC
Created attachment 1188604 [details]
Output of lspci -nn

Comment 3 Laurentiu Pancescu 2016-08-08 10:25:08 UTC
Created attachment 1188606 [details]
/proc/cpuinfo

Comment 4 Laurentiu Pancescu 2016-08-09 11:33:56 UTC

*** This bug has been marked as a duplicate of bug 1360705 ***


Note You need to log in before you can comment on or make changes to this bug.