Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364981 - Incorrect version in /etc/system-release-cpe
Summary: Incorrect version in /etc/system-release-cpe
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-release-rhev-hypervisor
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 10:07 UTC by cshao
Modified: 2016-08-08 15:11 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-08 15:11:56 UTC
oVirt Team: Node


Attachments (Terms of Use)

Description cshao 2016-08-08 10:07:34 UTC
Description of problem:
Incorrect version in /etc/system-release-cpe

#  cat /etc/system-release-cpe 
cpe:/o:redhat:enterprise_linux:7.2:beta:hypervisor


Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160803.3
imgbased-0.7.4-0.1.el7ev.noarch 

How reproducible:
100%

Steps to Reproduce:
1. Anaconda interactive install RHVH via ISO with default ks. 
2. cat /etc/system-release-cpe
3.

Actual results:
Incorrect version in /etc/system-release-cpe

Expected results:
like: cpe:/o: Red Hat Virtualization Host 4.0 (el7.2) 

Additional info:

Comment 1 Fabian Deutsch 2016-08-08 15:11:56 UTC
This is not a bug, it is intended.

On RHVH we align the user-visible strings with RHV.
But the general values used to identify an operating system are aligned with RHEL, this allows easy integration.


Note You need to log in before you can comment on or make changes to this bug.