Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364978 - EULA (End User License Agreement) is missing in RHVH
Summary: EULA (End User License Agreement) is missing in RHVH
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor-ng
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.1.1-1
: ---
Assignee: Ryan Barry
QA Contact: Qin Yuan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 10:06 UTC by cshao
Modified: 2017-04-20 18:58 UTC (History)
15 users (show)

Fixed In Version: redhat-release-virtualization-host-4.1-0.14.el7
Doc Type: Release Note
Doc Text:
Previously, Red Hat Virtualization Host (RHVH) was shipped without an End User License Agreement (EULA). In this release, this bug has been fixed and RHVH now includes an EULA.
Clone Of:
Environment:
Last Closed: 2017-04-20 18:58:51 UTC
oVirt Team: Node


Attachments (Terms of Use)
EULA (deleted)
2016-08-08 10:06 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1114 normal SHIPPED_LIVE redhat-virtualization-host bug fix and enhancement update 2017-04-20 22:57:46 UTC

Description cshao 2016-08-08 10:06:19 UTC
Created attachment 1188598 [details]
EULA

Description of problem:
EULA (End User License Agreement) is missing in RHVH

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160803.3
imgbased-0.7.4-0.1.el7ev.noarch 

How reproducible:
100%

Steps to Reproduce:
1. Anaconda interactive install RHVH via ISO with default ks. 
2. Finish the installation with correct steps.
3. Login RHVH, try to found EULA at /usr/share/redhat-release/EULA

Actual results:
EULA (End User License Agreement) is missing in RHVH

Expected results:
EULA (End User License Agreement) can be found in RHVH.

Additional info:

Comment 1 Fabian Deutsch 2016-08-08 15:09:42 UTC
Do we have an EULA for RHVH?

Comment 4 Fabian Deutsch 2016-09-26 15:04:05 UTC
We should be using https://www.redhat.com/en/about/red-hat-end-user-license-agreements

Which is probably the same EULA as in RHEL.

Comment 6 Fabian Deutsch 2017-02-21 09:21:44 UTC
Considering comment 5 the remaining gap is to add a eula file to the anaconda image, so that it can be reviewed during installation.

Comment 7 Sandro Bonazzola 2017-03-16 10:18:01 UTC
Ryan, can we add this to 4.1.1 image?

Comment 8 Ryan Barry 2017-03-16 15:43:53 UTC
We can definitely get this in (to 4.1.1 or 4.1.2), at least to the image. I'll find out where Anaconda keeps it

Comment 10 Ryan Barry 2017-03-30 22:51:04 UTC
The RHEL ISO doesn't seem to provide a way to get to this in Anaconda either (other than the file being present in /usr/share), so we won't worry about it, as Anaconda doesn't have a good hook for this other than adding an entirely new spoke ourselves.

Comment 12 Qin Yuan 2017-04-05 10:50:59 UTC
Test Versions:
RHVH-4.1-20170404.5-RHVH-x86_64-dvd1.iso
imgbased-0.9.20-0.1.el7ev.noarch
redhat-release-virtualization-host-4.1-0.14.el7.x86_64

Test Steps:
1. Install RHVH via ISO with default ks. 
2. Finish the installation with correct steps.
3. Login RHVH, try to found EULA at /usr/share/redhat-release-virtualization-host/EULA

Test Results:
1. After step2, the indication at the bottom of anaconda UI is "Use of this product is subject to the license agreement found at /usr/share/redhat-release/EULA".
2. After step3, can find EULA under /usr/share/redhat-release-virtualization-host/, and the content is the same as linked in comment #4.

The bug is fixed, but the directory of EULA presented on the UI is different from the real one after installation.

Comment 14 errata-xmlrpc 2017-04-20 18:58:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1114


Note You need to log in before you can comment on or make changes to this bug.