Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364947 - [downstream clone][RFE] - Deactivate storage domain only if ovf store was updated
Summary: [downstream clone][RFE] - Deactivate storage domain only if ovf store was upd...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Eyal Shenitzky
QA Contact: Yosi Ben Shimon
URL:
Whiteboard:
: 1477147 (view as bug list)
Depends On: 1321585 1523225
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 09:28 UTC by rhev-integ
Modified: 2018-05-15 17:40 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
In the current release, the storage domain is prevented from going into maintenance if the OVF update fails. An optional check box to force maintenance mode, if desired, has been added.
Clone Of: 1321585
Environment:
Last Closed: 2018-05-15 17:38:43 UTC
oVirt Team: Storage
ratamir: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 None None None 2018-05-15 17:40:57 UTC
oVirt gerrit 83368 None None None 2017-11-26 14:33:48 UTC
oVirt gerrit 83383 None None None 2017-11-26 14:35:21 UTC
oVirt gerrit 83437 None None None 2017-11-26 14:34:51 UTC

Comment 10 Marina 2016-10-05 17:48:00 UTC
I am changing this from RFE to a bug and setting the proper flags.
This is a flaw in the design and can lead into data loss on customer setups.

Comment 12 Allon Mureinik 2016-10-05 20:48:06 UTC
(In reply to Marina from comment #10)
> I am changing this from RFE to a bug and setting the proper flags.
> This is a flaw in the design and can lead into data loss on customer setups.

Hardly.
Please share a sensible reproduction to this issue - deleting the OVF store isn't something anyone should do.
Until then, targeting to a more appropriate version than 4.0.z.

Comment 14 Germano Veit Michel 2016-10-13 06:26:39 UTC
It's not only preventing to Detach/Deactivate if the OVFs updated. All the images must be in healthy condition before detaching, see BZ 1384321.

Comment 16 Marina 2016-10-31 16:26:08 UTC
Allon, do I understand correctly that OVF store should be updated once detach(maintenance?) command is issued? If this is the flow, then I think the problem is that for some reason the update didn't happen before detaching and the information was lost.

I do not think this bug is about preventing SD detachment while performing the update, but detaching it without having the updated information pushed to the OVF store on the domain.

Comment 17 Julio Entrena Perez 2016-11-01 14:33:16 UTC
(In reply to Marina from comment #16)
> but detaching it without having the updated information pushed
> to the OVF store on the domain.
That's correct.

Comment 23 Allon Mureinik 2017-09-12 12:37:13 UTC
This depends on an RFE that currently isn't targeted for 4.2 - pushing out.
Yaniv L, if you disagree, let's discuss and see if this RFE should be brought into 4.2.

Comment 27 Allon Mureinik 2017-11-23 12:38:35 UTC
Eyal - what's the status here? The BZ is in post, but I see no patches attached to it.

Comment 28 Yaniv Lavi 2017-11-26 12:25:30 UTC
*** Bug 1477147 has been marked as a duplicate of this bug. ***

Comment 30 Yosi Ben Shimon 2018-01-21 14:15:06 UTC
Eyal, can we move this bug to VERIFIED based on 
https://bugzilla.redhat.com/show_bug.cgi?id=1523225#c7 ?

Comment 31 Eyal Shenitzky 2018-01-22 06:50:30 UTC
Yes.

Comment 32 Yosi Ben Shimon 2018-01-22 11:19:19 UTC
OK.
Moving to VERIFIED.

Comment 38 errata-xmlrpc 2018-05-15 17:38:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488


Note You need to log in before you can comment on or make changes to this bug.