Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364923 - civetweb unable to write to its error_log_file
Summary: civetweb unable to write to its error_log_file
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: Casey Bodley
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 08:21 UTC by shilpa
Modified: 2017-07-30 15:44 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 09:00:17 UTC


Attachments (Terms of Use)

Description shilpa 2016-08-08 08:21:17 UTC
Description of problem:
While 'civetweb error_log_file=' is specified in ceph.conf, civetweb does not log anything in its error_log file. 
Refer to c#10 in https://bugzilla.redhat.com/show_bug.cgi?id=1320434


Version-Release number of selected component (if applicable):
10.2.2.-32

How reproducible:
Always

Comment 2 Casey Bodley 2016-08-08 14:44:11 UTC
Sorry, my comment #10 in https://bugzilla.redhat.com/show_bug.cgi?id=1320434 was a misdiagnosis.

Could you please verify that error_log_file works correctly by adding this to your 'rgw frontends' in ceph.conf:

rgw frontends = civetweb port=<port> error_log_file=/tmp/civetweb.error.log global_auth_file=/nonexistent

Then try to restart the gateway. It should fail to start, and produce output in /tmp/civetweb.error.log.

Comment 3 shilpa 2016-08-09 09:00:17 UTC
Works for me.


Note You need to log in before you can comment on or make changes to this bug.