Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364886 - inode leak in brick process [NEEDINFO]
Summary: inode leak in brick process
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: 3.7.14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Oleksandr Natalenko
QA Contact:
URL:
Whiteboard:
Depends On: 1344885
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 06:35 UTC by Oleksandr Natalenko
Modified: 2016-09-01 10:12 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.15
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-01 09:21:28 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
amukherj: needinfo? (rgowdapp)


Attachments (Terms of Use)

Description Oleksandr Natalenko 2016-08-08 06:35:12 UTC
Backport of https://bugzilla.redhat.com/show_bug.cgi?id=1344885 fix to 3.7.

Comment 1 Vijay Bellur 2016-08-08 06:37:13 UTC
REVIEW: http://review.gluster.org/15106 (libglusterfs/client_t: Dump the 0th client too) posted (#1) for review on release-3.7 by Oleksandr Natalenko (oleksandr@natalenko.name)

Comment 2 Vijay Bellur 2016-08-08 06:39:12 UTC
REVIEW: http://review.gluster.org/15107 (storage/posix: fix inode leaks) posted (#1) for review on release-3.7 by Oleksandr Natalenko (oleksandr@natalenko.name)

Comment 3 Vijay Bellur 2016-08-09 08:44:09 UTC
COMMIT: http://review.gluster.org/15106 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit cc55ecc217032c6412ef6a0de0bc78ae9a4b7d15
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Sun Jun 12 13:02:05 2016 +0530

    libglusterfs/client_t: Dump the 0th client too
    
    > Reviewed-on: http://review.gluster.org/14704
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    
    BUG: 1364886
    Change-Id: I565e81944b6670d26ed1962689dcfd147181b61e
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
    Reviewed-on: http://review.gluster.org/15106
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Vijay Bellur 2016-08-10 08:40:22 UTC
COMMIT: http://review.gluster.org/15107 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit a9e14f31bbd3a6f48b1974744a611b834a22a11e
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Thu Jun 16 12:03:19 2016 +0530

    storage/posix: fix inode leaks
    
    > Reviewed-on: http://review.gluster.org/14739
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    > Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    
    BUG: 1364886
    Change-Id: Ibd221ba62af4db17bea5c52d37f5c0ba30b60a7d
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
    Reviewed-on: http://review.gluster.org/15107
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 5 Kaushal 2016-09-01 09:21:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.15, please open a new bug report.

glusterfs-3.7.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-September/050714.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 6 Kaushal 2016-09-01 09:33:16 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.15, please open a new bug report.

glusterfs-3.7.15 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-September/050714.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 7 Atin Mukherjee 2016-09-01 10:12:51 UTC
I doubt that this patch fixes all the leaks, Raghavendra can you confirm?


Note You need to log in before you can comment on or make changes to this bug.