Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364869 - [RFE][Cinder][HC] Support device block size of 4096 bytes
Summary: [RFE][Cinder][HC] Support device block size of 4096 bytes
Keywords:
Status: CLOSED DUPLICATE of bug 1592916
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.6.8
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: ovirt-4.3.3
: 4.3.0
Assignee: Rob Young
QA Contact: Gil Klein
URL:
Whiteboard:
Depends On: 798947 1539837 1592916
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 05:17 UTC by Germano Veit Michel
Modified: 2019-03-24 14:32 UTC (History)
23 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 798947
Environment:
Last Closed: 2019-03-24 14:32:29 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2858311 None None None 2017-01-13 01:27:36 UTC

Description Germano Veit Michel 2016-08-08 05:17:56 UTC
+++ This bug was initially created as a clone of Bug #798947 +++

Description of problem:
If you use iSCSI storage with the SATA drives in the Advanced Format is not connected to the data center storage

Version-Release number of selected component (if applicable):
Fedora core 16 whith Ovirt Engine, ovirt-node-image-2.2.3-1.1.fc16 in Nodes. Open-E Data Storage whith 4*2Tb Western Digital RE HDDs

How reproducible:


Steps to Reproduce:
1. Create iSCSI partition in open-e
2. Attach iScsi target in Datacentre
3. Error log message: Failed in vdscommand to CreateVGVDS, error = Device block size is not supported: 'logblksize=512 phyblksize=4096'
  
Actual results: Error, iSCSI storage not connected

Expected results: Connected iSCSI storage

--- Additional comment from Dave Neary on 2013-03-07 12:06:39 EST ---

Hi Ilya,

This issue has previously been reported against Red Hat Enterprise Virtualization. It has been classified as a "request for enhancement" there - and will be prioritised as such for a future release.

Thanks for your report!
Dave.

--- Additional comment from Itamar Heim on 2013-03-08 02:45:51 EST ---

there is using 4k mode, and being able to work with them which iirc was already fixed in a later version than node you are using.
ayal?

--- Additional comment from Ayal Baron on 2013-03-09 15:31:14 EST ---

(In reply to comment #2)
> there is using 4k mode, and being able to work with them which iirc was
> already fixed in a later version than node you are using.
> ayal?


We do not yet support using devices with a logical block size > 512B

Comment 19 John Call 2018-05-31 18:18:23 UTC
Would you be so kind as to provide an update on this bug?

My customer needed a link to our official documentation showing that we can't work with native 4k devices.  I provided this link
https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.2/html-single/planning_and_prerequisites_guide/#storage-types

Comment 20 Yaniv Lavi 2018-06-11 06:42:30 UTC
(In reply to John Call from comment #19)
> Would you be so kind as to provide an update on this bug?
> 


We are looking to provide this support via Cinder, where RHV is not a part of the storage datapath.

Comment 28 Sandro Bonazzola 2019-01-28 09:43:49 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 30 Yaniv Kaul 2019-01-28 11:02:57 UTC
What's the next step?

Comment 31 Sahina Bose 2019-01-28 12:10:00 UTC
(In reply to Yaniv Kaul from comment #30)
> What's the next step?

This is dependent on Bug 1592916 targeted for 4.3.1

Comment 32 Sandro Bonazzola 2019-03-12 12:40:57 UTC
4.3.0 has been already released, automatically re-targeting to 4.3.3 for re-evaluation

Comment 33 Tal Nisan 2019-03-24 14:32:29 UTC

*** This bug has been marked as a duplicate of bug 1592916 ***


Note You need to log in before you can comment on or make changes to this bug.