Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364847 - The conflict between "exclusions" in "jboss-deployment-structure.xml" and 'export="true"' in "module.xml".
Summary: The conflict between "exclusions" in "jboss-deployment-structure.xml" and 'ex...
Keywords:
Status: CLOSED DUPLICATE of bug 1266122
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: RESTEasy
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: jboss-set
QA Contact: Katerina Odabasi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-08 03:06 UTC by xuzhan
Modified: 2016-11-12 05:53 UTC (History)
2 users (show)

Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-12 05:53:09 UTC
Type: Bug


Attachments (Terms of Use)
1 (deleted)
2016-08-08 03:11 UTC, xuzhan
no flags Details
2 (deleted)
2016-08-08 03:12 UTC, xuzhan
no flags Details
3 (deleted)
2016-08-08 03:13 UTC, xuzhan
no flags Details

Description xuzhan 2016-08-08 03:06:00 UTC
Description of problem:

In App's "jboss-deployment-structure.xml" file, customer set "exclusions" to exclude EAP's module "org.apache.httpcomponents", he used another version of those jars stored in WEB-INF/lib.
Then EAP loaded module "org.jboss.resteasy.resteasy-jaxrs" when deployed App:
~~~
DEBUG [org.jboss.as.server.deployment] (MSC service thread 1-6) Adding dependency ModuleDependency [identifier=org.jboss.resteasy.resteasy-jaxrs ...
~~~

However, this module("resteasy-jaxrs") has exported "org.apache.httpcomponents":
~~~module.xml~~~
<dependencies>
	<module name="org.apache.httpcomponents" />
	...
	<!-- exported -->
        <module name="org.apache.httpcomponents" export="true"/>
	...
~~~~~~~~~~~~~~~~

Finally, the App failed to get deployed due to use the wrong version of "org.apache.httpcomponents" and "java.lang.NoSuchMethodError" error appeared.
Customer has to exclude module "resteasy-jaxrs" as well to make App deployed.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Deploy attached war to EAP 6.4 standalone.
2. review log.
3.

Actual results:


Expected results:


Additional info:
In this scenario, it seems that "exclusions" and "export='true'" is a contradiction.
Please let us know do we have a workaround or any other setting to avoid it?

Comment 1 xuzhan 2016-08-08 03:11:05 UTC
Created attachment 1188528 [details]
1

Comment 2 xuzhan 2016-08-08 03:12:32 UTC
Created attachment 1188529 [details]
2

Comment 3 xuzhan 2016-08-08 03:13:48 UTC
Created attachment 1188530 [details]
3

Comment 6 Brad Maxwell 2016-11-12 05:53:09 UTC

*** This bug has been marked as a duplicate of bug 1266122 ***


Note You need to log in before you can comment on or make changes to this bug.