Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364819 - Fluentd 3.2.1 Overwrites previously existing MESSAGE fields
Summary: Fluentd 3.2.1 Overwrites previously existing MESSAGE fields
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: ewolinet
QA Contact: chunchen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-07 21:21 UTC by ewolinet
Modified: 2016-09-30 02:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, if logs are generated with a 'message' field that field was overwritten by fluentd due to a field mapping error. We have corrected that error ensuring that the 'message' field is preserved if it exists.
Clone Of:
Environment:
Last Closed: 2016-08-11 18:38:42 UTC


Attachments (Terms of Use)
abnormal message field (deleted)
2016-08-08 06:16 UTC, Xia Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1608 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 3.2.1.13 bug fix and enhancement update 2016-08-11 22:37:53 UTC

Description ewolinet 2016-08-07 21:21:13 UTC
Description of problem:
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1324996

Missing in 3.2.1+

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Xia Zhao 2016-08-08 06:16:16 UTC
Created attachment 1188542 [details]
abnormal message field

Reproduced this bz with OSE v3.2.1.13, see "message : - " on Kibana UI

Logging images tested with:
openshift3/logging-deployment    d7efd0e669f7
openshift3/logging-fluentd    b9d93af1c7fd
openshift3/logging-auth-proxy    a717e4a4928c
openshift3/logging-kibana    4a72ca86d765
openshift3/logging-elasticsearch    d093af1c6478

Openshift version:
openshift v3.2.1.13-1-gc2a90e1
kubernetes v1.2.0-36-g4a3f9c5
etcd 2.2.5

Comment 3 Xia Zhao 2016-08-09 02:57:49 UTC
Verified with the latest fluend image, bug fixed well, the messages field is now "timer: Hello from control: 1470711149001" on Kibana UI, which looks good.

Images tested:
openshift3/logging-fluentd    77a64b668f70
openshift3/logging-deployment    d7efd0e669f7
openshift3/logging-auth-proxy    a717e4a4928c
openshift3/logging-kibana    4a72ca86d765
openshift3/logging-elasticsearch    d093af1c6478

Openshift version:
openshift v3.2.1.13-1-gc2a90e1
kubernetes v1.2.0-36-g4a3f9c5
etcd 2.2.5

Comment 5 errata-xmlrpc 2016-08-11 18:38:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1608


Note You need to log in before you can comment on or make changes to this bug.