Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364733 - need cecil.pc
Summary: need cecil.pc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mono-cecil
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Timotheus Pokorra
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-06 19:01 UTC by Timotheus Pokorra
Modified: 2018-05-08 20:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-08 20:47:07 UTC


Attachments (Terms of Use)
need that in rpm mono-cecil-devel (deleted)
2016-08-06 19:01 UTC, Timotheus Pokorra
no flags Details
patch for the spec file, and the cecil.pc file (deleted)
2016-08-09 06:34 UTC, Timotheus Pokorra
no flags Details | Diff

Description Timotheus Pokorra 2016-08-06 19:01:40 UTC
Created attachment 1188229 [details]
need that in rpm mono-cecil-devel

I am in the process of unbundling Mono.Cecil from the mono package, and using mono-cecil instead (#1360620).
It seems that cecil.pc is missing from mono-cecil (or perhaps mono-cecil-devel?).
In the mono package, the file cecil.pc was delivered in the rpm mono-devel, /usr/lib64/pkgconfig/cecil.pc

Without cecil.pc, package mono-tools does not build currently.

I have attached a cecil.pc that should work.

Comment 1 Miro Hrončok 2016-08-06 19:29:25 UTC
1) How was the file created?

2) Where does it belong?

Please note that I don't know much about Mono, I package this as a dependency, not because I know Mono :D

Comment 2 Timotheus Pokorra 2016-08-06 19:35:17 UTC
1) It is a text file basically. See also https://github.com/mono/mono/blob/master/data/cecil.pc.in, that was the source for that file that was packaged with the mono-devel rpm

2) it should belong to mono-cecil-devel, and live in /usr/lib64/pkgconfig/cecil.pc

If you want to know more about how Mono uses pkgconfig files for assemblies (dlls), you can read http://www.mono-project.com/docs/advanced/assemblies-and-the-gac/#libraries-with-unstable-apis

I am happy to help with mono-cecil, I have applied for ACL. Then I could modify the mono-cecil.spec for you, and include the pc file.

Comment 3 Timotheus Pokorra 2016-08-06 19:40:03 UTC
2) sorry, /usr/lib64 is bad obviously. in the mono.spec file it was:
%{_libdir}/pkgconfig/cecil.pc

see the commit where I removed Mono.Cecil from the mono package:
http://pkgs.fedoraproject.org/cgit/rpms/mono.git/commit/?id=20e71e08b471b636120a622b2321ae1bdaf66b7f

Comment 4 Timotheus Pokorra 2016-08-09 06:34:39 UTC
Created attachment 1189043 [details]
patch for the spec file, and the cecil.pc file

Comment 5 Miro Hrončok 2016-08-09 09:32:34 UTC
Approved ACLs, feel free to push and build this.

Thanks

Comment 6 Timotheus Pokorra 2016-08-09 10:11:56 UTC
thanks for the approved ACLs!

It is fixed now in rawhide.

Comment 7 Miro Hrončok 2016-08-10 14:16:54 UTC
mono-debugger has broken dependencies in the rawhide tree:
On x86_64:
	mono-debugger-2.10-11.fc23.x86_64 requires mono(Mono.Cecil) = 0:0.9.5.0
On i386:
	mono-debugger-2.10-11.fc23.i686 requires mono(Mono.Cecil) = 0:0.9.5.0
Please resolve this as soon as possible.

mono-tools has broken dependencies in the rawhide tree:
On x86_64:
	mono-tools-4.2-2.fc24.x86_64 requires mono(Mono.Cecil) = 0:0.9.5.0
On i386:
	mono-tools-4.2-2.fc24.i686 requires mono(Mono.Cecil) = 0:0.9.5.0
On armhfp:
	mono-tools-4.2-2.fc24.armv7hl requires mono(Mono.Cecil) = 0:0.9.5.0
On x86_64:
	mono-tools-gendarme-4.2-2.fc24.x86_64 requires mono(Mono.Cecil) = 0:0.9.5.0
On i386:
	mono-tools-gendarme-4.2-2.fc24.i686 requires mono(Mono.Cecil) = 0:0.9.5.0
On armhfp:
	mono-tools-gendarme-4.2-2.fc24.armv7hl requires mono(Mono.Cecil) = 0:0.9.5.0
Please resolve this as soon as possible.

mono-cecil-flowanalysis has broken dependencies in the rawhide tree:
On x86_64:
	mono-cecil-flowanalysis-0.1-0.26.20110512svn100264.fc24.x86_64 requires mono(Mono.Cecil) = 0:0.9.5.0
On i386:
	mono-cecil-flowanalysis-0.1-0.26.20110512svn100264.fc24.i686 requires mono(Mono.Cecil) = 0:0.9.5.0
On armhfp:
	mono-cecil-flowanalysis-0.1-0.26.20110512svn100264.fc24.armv7hl requires mono(Mono.Cecil) = 0:0.9.5.0
Please resolve this as soon as possible.

Comment 8 Timotheus Pokorra 2016-08-10 21:53:54 UTC
I have fixed mono-tools, and rebuilt it yesterday (mono-tools-4.2-3.fc26). Somehow Rawhide does not deliver that new package yet.

For mono-debugger, I have prepared a solution locally, and have asked chkr for ACL permissions, which he has given to me for other mono packages in the past already. mono-debugger is FTBFS since Fedora 24, but I have a solution for that.

For mono-cecil-flowanalysis, a rebuild is probably sufficient. I have triggered that. If it needs an increased version number, I will contact the maintainer.

Comment 9 Fedora End Of Life 2017-02-28 10:04:02 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.

Comment 10 Fedora End Of Life 2018-05-03 08:31:34 UTC
This message is a reminder that Fedora 26 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 26. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '26'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 26 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 11 Timotheus Pokorra 2018-05-08 20:47:07 UTC
I think this has been fixed a long time ago


Note You need to log in before you can comment on or make changes to this bug.