Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364705 - kerberos: fail early on ticket request when ticketing disabled
Summary: kerberos: fail early on ticket request when ticketing disabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-online-accounts
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Debarshi Ray
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1267534
TreeView+ depends on / blocked
 
Reported: 2016-08-06 10:26 UTC by Matěj Cepl
Modified: 2016-11-04 01:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 01:03:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2223 normal SHIPPED_LIVE gnome-online-accounts bug fix update 2016-11-03 13:26:02 UTC
GNOME Bugzilla 756498 None None None 2016-08-06 10:26:40 UTC

Description Matěj Cepl 2016-08-06 10:26:41 UTC
Description of problem:
See bug 1267534 for details and tracebacks. According to rishi, this is a known upstream bug 

rishi: That's known and fixed upstream. But I'd argue that it is a different bug.
rishi: Maybe file another downstream bug.
rishi:  The original bug didn't say anything about flipping the switch *and* restarting the daemons. :)
rishi: I believe this should fix it for you: https://bugzilla.gnome.org/show_bug.cgi?id=756498
mcepl: well, but would you added it to 7.3 if I file the bug now? SHouldn't we add this fix on 1267534 rather?
rishi: I am saying that the crash you are seeing isn't specifically  about restarting the daemon. If you flip the switch while the daemon is trying to refresh the Kerberos credentials it will crash.
rishi: I don't have a strong opinion on how granular the bug reports should be.

Version-Release number of selected component (if applicable):
gnome-online-accounts-3.14.5-3.el7.x86_64

How reproducible:
100% (2 out of 2)

Steps to Reproduce:
1. see above and the other bug
2.
3.

Actual results:
Crash

Expected results:
No crash, and Kerberos password asked for (if needed).

Additional info:

Comment 1 Debarshi Ray 2016-08-10 17:50:36 UTC
I have built gnome-online-accounts-3.14.5-4.el7 with a possible fix:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=11546495

Comment 3 Matěj Cepl 2016-08-31 17:56:14 UTC
No crashes anymore with gnome-online-accounts-3.14.5-5.el7.x86_64

Comment 5 errata-xmlrpc 2016-11-04 01:03:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2223.html


Note You need to log in before you can comment on or make changes to this bug.