Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364666 - libnss_wins.so.2 has missing dependency
Summary: libnss_wins.so.2 has missing dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1370875 1438116 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-06 08:54 UTC by Ralf Ertzinger
Modified: 2017-04-15 22:47 UTC (History)
13 users (show)

Fixed In Version: samba-4.5.8-1.fc25 samba-4.4.13-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-09 21:51:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Samba Project 12277 None None None 2017-04-06 14:08:23 UTC

Description Ralf Ertzinger 2016-08-06 08:54:39 UTC
Description of problem:
libnss_wins.so.2 is supposed to link against libreplace-samba4.so, but the file cannot be found:

$ ldd /lib64/libnss_wins.so.2
        linux-vdso.so.1 (0x00007ff50e8eb000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007ff50e499000)
        libwbclient.so.0 => /lib64/libwbclient.so.0 (0x00007ff50e28b000)
        libreplace-samba4.so => not found
        libc.so.6 => /lib64/libc.so.6 (0x00007ff50dec8000)
        /lib64/ld-linux-x86-64.so.2 (0x000055dd894f9000)
        libwinbind-client-samba4.so => /usr/lib64/samba/libwinbind-client-samba4.so (0x00007ff50dcc4000)
        libreplace-samba4.so => /usr/lib64/samba/libreplace-samba4.so (0x00007ff50dac0000)

This leads to nss wins resolution not working.

Version-Release number of selected component (if applicable):
samba-winbind-modules-4.4.5-1.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ralf Ertzinger 2016-08-06 08:55:18 UTC
Additional note: /usr/lib64/samba/libreplace-samba4.so is present on the system.

Comment 2 Florian Weimer 2017-03-14 11:59:43 UTC
*** Bug 1370875 has been marked as a duplicate of this bug. ***

Comment 3 Florian Weimer 2017-04-06 13:43:25 UTC
*** Bug 1438116 has been marked as a duplicate of this bug. ***

Comment 4 Andreas Schneider 2017-04-06 13:55:24 UTC
Fixed with Samba 4.4.9 and newer. Current version is 4.4.12.

Comment 5 Florian Weimer 2017-04-06 14:08:24 UTC
Still present in samba-winbind-modules-2:4.4.10-0.fc24 and samba-winbind-modules-2:4.5.8-0.fc25.

Comment 6 Fedora Update System 2017-04-06 15:13:45 UTC
samba-4.4.13-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-97fb93e1d1

Comment 7 Fedora Update System 2017-04-06 20:13:40 UTC
samba-4.5.8-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-196d4a22fa

Comment 8 Fedora Update System 2017-04-07 19:53:36 UTC
samba-4.4.13-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-97fb93e1d1

Comment 9 Fedora Update System 2017-04-07 19:57:36 UTC
samba-4.5.8-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-196d4a22fa

Comment 10 Fedora Update System 2017-04-09 21:51:37 UTC
samba-4.5.8-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2017-04-15 22:47:55 UTC
samba-4.4.13-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.