Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364604 - Upstream Bug 56925 - ErrorDocument directive misbehaves with mod_proxy_http and mod_proxy_ajp
Summary: Upstream Bug 56925 - ErrorDocument directive misbehaves with mod_proxy_http a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: httpd
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Luboš Uhliarik
QA Contact: Jan Houska
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-05 22:25 UTC by Joe
Modified: 2017-08-01 21:36 UTC (History)
5 users (show)

Fixed In Version: httpd-2.4.6-58.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 21:36:44 UTC


Attachments (Terms of Use)
Patch fixing the issue (deleted)
2016-09-26 13:52 UTC, Luboš Uhliarik
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Apache Bugzilla 56925 None None None 2016-08-05 22:25:16 UTC
Red Hat Product Errata RHBA-2017:2175 normal SHIPPED_LIVE httpd bug fix update 2017-08-01 18:40:47 UTC

Description Joe 2016-08-05 22:25:16 UTC
Description of problem:
If custom error responses are configured with ErrorDocument and mod_proxy_http or mod_proxy_ajp is used, httpd will wait for the configured proxytimeout before serving the error document.

Version-Release number of selected component (if applicable):
2.4.6-40.el7.x86_64

How reproducible:
Create the following test configuration:
ErrorDocument 404 http://bugzilla.redhat.com
ProxyErrorOverride on
ProxyPass / http://127.0.0.1/nonexistant
ProxyPassReverse / http://127.0.0.1/nonexistant

Steps to Reproduce:
1. Open http://127.0.0.1/ in a webbrowser

Actual results:
It takes 20 seconds until the redirect to http://bugzilla.redhat.com is executed.
The time this takes can be "adjusted" by changing the proxy timeout parameter, for example 5 seconds: ProxySet timeout=5

Expected results:
The redirect to http://bugzilla.redhat.com is executed immediately.

Additional info:
The same error also occurs for ErrorDocument 500, 503 etc. configurations.
The bug was already fixed upstream: https://bz.apache.org/bugzilla/show_bug.cgi?id=56925

Comment 4 Luboš Uhliarik 2016-09-26 13:52:29 UTC
Created attachment 1204843 [details]
Patch fixing the issue

Comment 11 errata-xmlrpc 2017-08-01 21:36:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2175


Note You need to log in before you can comment on or make changes to this bug.