Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364584 - OSP8 Undercloud metrics not being collected by C&U. Specifically CPU metrics but others are missing as well
Summary: OSP8 Undercloud metrics not being collected by C&U. Specifically CPU metrics ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: All
OS: All
high
high
Target Milestone: GA
: 5.8.0
Assignee: Tzu-Mainn Chen
QA Contact: Ola Pavlenko
URL:
Whiteboard: openstack
Depends On: 1365560 1365907
Blocks: 1397405
TreeView+ depends on / blocked
 
Reported: 2016-08-05 20:11 UTC by Kevin Morey
Modified: 2017-08-30 03:44 UTC (History)
15 users (show)

Fixed In Version: 5.8.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1397405 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:11:28 UTC
Category: ---
Cloudforms Team: Openstack


Attachments (Terms of Use)

Description Kevin Morey 2016-08-05 20:11:12 UTC
Description of problem:
There appears to be a mismatch of the metrics that CF is going after and the ones that the undercloud ships with out of the box. 

hardware.system_stats.cpu.util => This i believe is the reason we are not getting CPU metrics in CF. CF is looking for that stat and it is not in the undercloud. Perhaps a ceilometer parameter is missing and this is a RHOS-director issue?

Regardless there are other metrics that are not being collected as well.

Version-Release number of selected component (if applicable):
5.6.0.13 and 5.6.1.0

How reproducible:
100%


Additional info:

From the undercloud:

$ ceilometer meter-list | awk '{ print $2 }' | sort | uniq

hardware.memory.buffer
hardware.memory.total
hardware.memory.used
hardware.network.incoming.bytes
hardware.network.outgoing.bytes
image
image.size
Name
storage.containers.objects
storage.containers.objects.size
storage.objects
storage.objects.containers
storage.objects.size



From CloudForms:

# more /var/www/miq/vmdb/app/models/manageiq/providers/openstack/infra_manager/metrics_capture.rb

class ManageIQ::Providers::Openstack::InfraManager::MetricsCapture < ManageIQ::Providers::Openstack::BaseMetricsCapture
  CPU_METERS     = %w(hardware.system_stats.cpu.util)
  MEMORY_METERS  = %w(hardware.memory.used
                      hardware.memory.total)
  SWAP_METERS    = %w(hardware.memory.swap.avail
                      hardware.memory.swap.total)
  DISK_METERS    = %w(hardware.system_stats.io.outgoing.blocks
                      hardware.system_stats.io.incoming.blocks)
  NETWORK_METERS = %w(hardware.network.ip.incoming.datagrams
                      hardware.network.ip.outgoing.datagrams)
...

Comment 8 Satoe Imaishi 2016-11-22 02:28:13 UTC
Mainn, can you please add PR link?

Comment 9 Tzu-Mainn Chen 2016-11-22 12:52:11 UTC
https://github.com/ManageIQ/manageiq/pull/12735

Comment 11 Ronnie Rasouli 2017-03-08 07:25:39 UTC
verified on 5.8.0.3


Note You need to log in before you can comment on or make changes to this bug.