Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364574 - JBoss ON 3.3 is not correlating the hierarchy correctly when using JMX Server Plugin
Summary: JBoss ON 3.3 is not correlating the hierarchy correctly when using JMX Server...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other
Version: JON 3.3.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: JON 3.3.8
Assignee: Simeon Pinder
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-05 19:23 UTC by Amana
Modified: 2016-11-22 16:37 UTC (History)
8 users (show)

Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-22 16:37:23 UTC
Type: Bug


Attachments (Terms of Use)
jconsole1 (deleted)
2016-08-05 19:23 UTC, Amana
no flags Details
jon1 (deleted)
2016-08-05 19:24 UTC, Amana
no flags Details

Description Amana 2016-08-05 19:23:44 UTC
Created attachment 1188003 [details]
jconsole1

##Description of problem:

We found that the nesting of the hierarchy is wrong when using JMX Server plugin to monitor MBeans in JBoss ON. 

The test was performed with JON 3.3.5 + BPM Suite Plugin (latest available). After enabling MBeans for BPM Suite, a JMX Server was created in JON side to monitor it.

After discovering the MBeans, we found that hierarchy is wrong. The BxMS plugin structure is:

 - Kie Service
   - Kie Bases
     - Kie Sessions

In jconsole1.png, you can see that under "org.drools.kbases" there are three kbases and under each kbase there is one ksession-0:

  22824cf3-a184-42df-a76f-287687a5eca8
    - ksession-0
  9de9b0d7-f5ec-4520-948b-a05e2b8623fe 
    - ksession-0
  b4c11274-46ba-4c14-b6ef-704f77ad7cfa 
    - ksession-0

In jon1.png, the same three kbases are listed , but there are three ksession-0 under each one of them. By clicking on that, we see that JON is listing all ksessions (from any kbases) under all kbases. See that the ksession selected in the picture actually refers to kbase "9de9b0d7-f5ec-4520-948b-a05e2b8623fe", then it is being displayed under the wrong kbase.

Since drools plugin makes use of the discovery from the jmx plugin, it seems to be an issue on it.






Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Amana 2016-08-05 19:24:10 UTC
Created attachment 1188004 [details]
jon1

Comment 2 Amana 2016-08-05 19:25:57 UTC
Hi all,

This is an issue that we found by performing internal tests. Please let me know if any further information is needed to proceed with it and if it is possible to fix that.

Thanks in advance!

Comment 3 Jozef Marko 2016-09-29 10:51:38 UTC
The wrong hierarchy shown by drools-rhq-plugin was already fixed by solving of [1]. Unfortunately, the fix doesn't work with latest JON [2] available on the customer portal. It is probably necessary to adapt also the latest JON to collaborate with the latest drools-rhq-plugin [3].


[1]
https://issues.jboss.org/browse/BPMSPL-517
[2]
jon-server-3.3.0.GA-update-07
[3]
https://repository.jboss.org/nexus/content/groups/public/org/drools/drools-rhq-plugin/6.5.0-SNAPSHOT/

Comment 4 Jozef Marko 2016-09-30 12:41:01 UTC
Here [1] can be found google document with more details, how to reproduce my issue. 

Here are also some details of environments when guide from [1] works and when it doesn't work:

jon-server-3.3.0.GA-update-07  \
drools-project [2]              > works 
drools-rhq-plugin [3]          /


jon-server-3.3.0.GA-update-07  \
drools-project [4]              > does not work
latest drools-rhq-plugin [5]   /


[1]
https://docs.google.com/a/redhat.com/document/d/1-6EHmzfUl_bAmC5yT0oj27OuS4ESk3rCzNGIJyDKEAA/edit?usp=sharing
[2]
https://github.com/jomarko/drools-project/tree/6.4.x
[3]
http://download-node-02.eng.bos.redhat.com/brewroot/repos/jb-bxms-6.4-build/latest/maven/org/drools/drools-rhq-plugin/6.4.0.Final-redhat-10/
[4]
https://github.com/jomarko/drools-project/
[5]
https://repository.jboss.org/nexus/content/groups/public/org/drools/drools-rhq-plugin/6.5.0-SNAPSHOT/

Comment 5 Edson Tirelli 2016-09-30 14:11:05 UTC
Jozef,

As I mentioned in the e-mail thread, you can't compare the current version of the plugin to the previous one because the previous one did not publish/present the data properly.

The real problem here is that Matteo did the changes following the advise from the JON team and tested the changes using community RHQ 4.13.0.

Unfortunately, when you tried to test the plugin on JON 3.3.0-update-07 as you described above, it is not working.

So, we need advise from the JON team about what is wrong? We are not familiar with the version mapping between RHQ and JON, so what do we need to do to fix the plugin for JON 3.3.0 or, if the problem is not on the plugin side, what is it necessary to do on the JON side to fix it?

Comment 6 Josejulio Martínez 2016-09-30 17:01:02 UTC
I found this on the log [1] provided by mail.
I'm not familiar with this, but might be relevant.

---
2016-09-15 08:37:08,444 DEBUG [ResourceDiscoveryComponent.invoker.daemon-1] (org.rhq.plugins.jmx.JMXDiscoveryComponent)- Process [8622] with command line [[/home/jomarko/tools/jdk1.8.0_65/bin/java, -classpath, /home/jomarko/tools/apache-maven-3.3.3/boot/plexus-classworlds-2.5.2.jar, -Dclassworlds.conf=/home/jomarko/tools/apache-maven-3.3.3/bin/m2.conf, -Dmaven.home=/home/jomarko/tools/apache-maven-3.3.3, -Dmaven.multiModuleProjectDirectory=/home/jomarko/redhat/servers/jon/drools-project, org.codehaus.plexus.classworlds.launcher.Launcher, clean, install, exec:exec]] cannot be discovered, because it does not specify either of the following system properties: -Dcom.sun.management.jmxremote.port=12345, -Dorg.rhq.resourceKey=UNIQUE_KEY

---

Do you know if this is relevant (Larry, Michael)?

[1] https://gist.githubusercontent.com/jomarko/61868444bddf80d574db317de53654e7/raw/fdfe982d892d65641274013d318e37efaf605448/agent.log

Comment 7 Larry O'Leary 2016-09-30 17:21:23 UTC
It does not appear so. 

That process appears to be the Maven process which was used to launch/deploy the Drools project.

Comment 8 Josejulio Martínez 2016-10-06 04:15:15 UTC
This appear to be fixed on JON with latest change [1]

[1] https://issues.jboss.org/browse/DROOLS-1316


Note You need to log in before you can comment on or make changes to this bug.