Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364568 - Upgrading_the_Self-Hosted_Engine_from_6_to_7.html does not state el7 host should be first 3.5
Summary: Upgrading_the_Self-Hosted_Engine_from_6_to_7.html does not state el7 host sho...
Keywords:
Status: CLOSED DUPLICATE of bug 1328382
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 3.6.8
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: rhev-docs@redhat.com
QA Contact: rhev-docs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-05 18:23 UTC by Jiri Belka
Modified: 2016-08-09 11:38 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 11:38:47 UTC
oVirt Team: Docs


Attachments (Terms of Use)

Description Jiri Belka 2016-08-05 18:23:04 UTC
Description of problem:

$url/ovirt-engine/docs/manual/en_US/html/Self-Hosted_Engine_Guide/Upgrading_the_Self-Hosted_Engine_from_6_to_7.html states:

~~~
The upgrade process ...:

...
* Upgrade all version 6 hosts to version 7. Re-run hosted-engine --deploy on all self-hosted engine hosts.
* Upgrade the self-hosted engine hosts to Red Hat Enterprise Virtualization 3.6.
..
~~~

But if an admin would do this migration of 3.5 EL6 based SHE env after release of 3.6, he would have 3.6 rpms in the channel, wouldn't he?

Thus he would be having EL7 and during `yum install ovirt-hosted-engine-setup' he would and with 3.6 rpms.

If he would continue with EL7 and 3.6 rpms SHE deployment to existing 3.5 EL6 SHE host, he would see an error stating that he cannot mix 3.5 and 3.6 and that he should update the hosts.

Thus, IMO the documention should state clearly that first step should be EL7 with 3.5 rpms. But how would you do that? IIUC all host replated rpms are shipped into just one repo.

No idea how to do that? Populate an yum version lock list with exact (ie. 3.5) rpms versions?


Version-Release number of selected component (if applicable):
rhevm-doc-3.6.8-1.el6eng.noarch

How reproducible:
100%

Steps to Reproduce:
1. have EL6 3.5 SHE host, engine 3.6 with InClusterUpgrade scheduling policy set
2. add EL7 host, register rhel-7-server-rhev-mgmt-agent-rpms channel (after 3.6 release)
3. hosted-engine --deploy

Actual results:
deployment fails as the user cannot mix 3.5 and 3.6

Expected results:
the admin should have clear understanding the EL7 host should be 3.5 first (ie. during deployment)

Additional info:
please clarify with developers

Comment 1 Yaniv Lavi 2016-08-09 11:38:47 UTC

*** This bug has been marked as a duplicate of bug 1328382 ***


Note You need to log in before you can comment on or make changes to this bug.