Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364556 - Scrollbars do not Appear on Pages that Require Them in Horizon
Summary: Scrollbars do not Appear on Pages that Require Them in Horizon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On: 1356713
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-05 17:09 UTC by Mike Burns
Modified: 2016-08-24 12:58 UTC (History)
11 users (show)

Fixed In Version: python-django-horizon-9.0.1-2.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of: 1356713
Environment:
Last Closed: 2016-08-24 12:58:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1757 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 Bug Fix and Enhancement Advisory 2016-08-24 16:50:17 UTC

Description Mike Burns 2016-08-05 17:09:45 UTC
Clone for OSP 9

+++ This bug was initially created as a clone of Bug #1356713 +++

Description of problem:
When viewing various pages in the Horizon UI for Red Hat OpenStack Platform it is possible for the content of the page to be longer than the current browser window can display. However, currently there is no way to scroll in these pages. Scrolling the mouse wheel, using the arrow keys, or page up/down have no effect on the page. This can cause information to be cut off from the user.

Version-Release number of selected component (if applicable):
python-django-horizon-9.0.0-5.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install the python-django-horizon package on an OpenStack instance (I used packstack)
2. Log in to the Horizon UI.
3. Navigate to any page or tab.
4. Resize the vertical size of the browser window
5. Observe that no scrollbars are present or appear and there is no means to scroll the content of the page.

Actual results:
No scrollbars or means of scrolling appear on pages that need them.

Expected results:
If a page needs to be scrolled, scroll bars will appear and the user can use the mouse and keyboard to navigate the page.

Additional info:
This was observed against 
  - Google Chrome Version 51.0.2704.106 (64-bit) on Fedora 24
  - Firefox 47.0 on Fedora 24
Another interesting note is that if the browser window is resized to be very short, the top bar (where "Red Hat OpenStack Platform" and the tabs are) DOES get a scroll bar. It appears to be isolated to the content being displayed in the frame beneath it.

--- Additional comment from Radomir Dopieralski on 2016-08-05 07:00:00 EDT ---

This is due to position:fixed on the #content_body div. Should be position:absolute instead.

Comment 4 Ola Pavlenko 2016-08-24 09:53:14 UTC
Verified
========
OSPD9 latest bits
python-django-horizon-9.0.1-2.el7ost.noarch

Comment 5 errata-xmlrpc 2016-08-24 12:58:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1757.html


Note You need to log in before you can comment on or make changes to this bug.