Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364529 - api: revert glfs_ipc_xd intended for 4.0
Summary: api: revert glfs_ipc_xd intended for 4.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact: Sudhir D
URL:
Whiteboard:
: 1383591 (view as bug list)
Depends On:
Blocks: glusterfs-3.9.0 1370931
TreeView+ depends on / blocked
 
Reported: 2016-08-05 15:35 UTC by Niels de Vos
Modified: 2016-12-06 05:59 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1345977
Environment:
Last Closed: 2016-12-06 05:59:14 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-08-05 15:35:54 UTC
+++ This bug was initially created as a clone of Bug #1345977 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-06-13 17:00:28 CEST ---

REVIEW: http://review.gluster.org/14716 (api: revert addition of glfs_ipc_xd()) posted (#1) for review on release-3.8 by Kaleb KEITHLEY (kkeithle@redhat.com)

--- Additional comment from Vijay Bellur on 2016-06-13 20:58:27 CEST ---

COMMIT: http://review.gluster.org/14716 committed in release-3.8 by Jeff Darcy (jdarcy@redhat.com) 
------
commit f4e5841eb6f132174e65ccad91fd2f6021771f29
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Mon Jun 13 10:56:56 2016 -0400

    api: revert addition of glfs_ipc_xd()
    
    It is intended for 4.0
    
    Change-Id: Ieffe1d966234652091a4a9ae0b2c4b23f1297147
    BUG: 1345977
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/14716
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

--- Additional comment from Niels de Vos on 2016-06-16 14:34:04 CEST ---

This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 1 Niels de Vos 2016-10-14 07:50:39 UTC
*** Bug 1383591 has been marked as a duplicate of this bug. ***

Comment 2 Worker Ant 2016-10-14 13:18:56 UTC
REVIEW: http://review.gluster.org/15642 (api: revert addition of glfs_ipc_xd()) posted (#1) for review on release-3.9 by Niels de Vos (ndevos@redhat.com)

Comment 3 Worker Ant 2016-10-14 20:29:19 UTC
COMMIT: http://review.gluster.org/15642 committed in release-3.9 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit a95fd26fd1c7c336cb3eaaf61779883ab69b66b0
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Oct 14 15:10:36 2016 +0200

    api: revert addition of glfs_ipc_xd()
    
    It is intended for 4.0
    
    Cherry picked from commit f4e5841eb6f132174e65ccad91fd2f6021771f29:
    > Change-Id: Ieffe1d966234652091a4a9ae0b2c4b23f1297147
    > BUG: 1345977
    > Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    > Reviewed-on: http://review.gluster.org/14716
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    > Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    
    Note that this 'backport' is done on a patch from the release-3.8
    branch, and it not part of the master branch.
    
    Change-Id: Ieffe1d966234652091a4a9ae0b2c4b23f1297147
    BUG: 1364529
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/15642
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 4 Aravinda VK 2016-10-27 05:22:56 UTC
glusterfs-3.9.0rc2 is released[1] and packages are available for different distributions[2] to test.

[1] http://www.gluster.org/pipermail/maintainers/2016-October/001601.html
[2] http://www.gluster.org/pipermail/maintainers/2016-October/001605.html and http://www.gluster.org/pipermail/maintainers/2016-October/001606.html

Comment 5 Aravinda VK 2016-12-06 05:59:14 UTC
Gluster 3.9 GA is released http://blog.gluster.org/2016/11/announcing-gluster-3-9/


Note You need to log in before you can comment on or make changes to this bug.