Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364520 - Unable to add new registry elements to Analysis Profiles
Summary: Unable to add new registry elements to Analysis Profiles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: All
OS: All
medium
high
Target Milestone: GA
: 5.7.0
Assignee: Robin Knaur
QA Contact: Matouš Mojžíš
URL:
Whiteboard: ui:configuration:smartstate
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-05 14:55 UTC by Kevin Morey
Modified: 2017-01-18 02:32 UTC (History)
10 users (show)

Fixed In Version: 5.7.0.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-04 12:59:14 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (deleted)
2016-08-05 14:55 UTC, Kevin Morey
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0012 normal SHIPPED_LIVE CFME 5.7.0 bug fixes and enhancement update 2017-01-04 17:50:36 UTC

Description Kevin Morey 2016-08-05 14:55:20 UTC
Created attachment 1187938 [details]
screenshot

Description of problem:
We are unable to add new 'registry' elements to Smart State Analysis Profiles.

Version-Release number of selected component (if applicable):
5.6.0.13 & 5.6.1.0

How reproducible:
everytime

Steps to Reproduce:
1. Navigate to Configuration / Settings
2. Copy the 'sample' VM profile to one called 'default'
3. Edit default, click on registry
4. Attempt to add a new registry element like 'SOFTWARE\Foo', 'Bar'

Actual results:
Unable to save the entered data

Expected results:
expected to save the entered data

Additional info:
see screenshot

Comment 2 Harpreet Kataria 2016-08-05 18:14:22 UTC
Eric,

Can you take a look at this, image_submit_tag does not seem to be working, i see that you have replaced those with buttons/font icons on the other tabs on the same screen, can you also take care of the left over ones on this screen. Let me know if you have questions.

Thanks,
~Harpreet

Comment 4 CFME Bot 2016-09-16 11:06:01 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/7f13e81834d43c789cfe2defc8095be5bf7d8918

commit 7f13e81834d43c789cfe2defc8095be5bf7d8918
Author:     Robin Knaur <rknaur@redhat.com>
AuthorDate: Wed Sep 7 13:08:48 2016 +0200
Commit:     Robin Knaur <rknaur@redhat.com>
CommitDate: Wed Sep 7 13:08:48 2016 +0200

    Add new registy elements to Analysis Profiles fix
    https://bugzilla.redhat.com/show_bug.cgi?id=1364520

 app/views/ops/_ap_form_registry.html.haml | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

Comment 5 Matouš Mojžíš 2016-11-07 17:42:35 UTC
Verified in 5.7.0.9. I cann add new registry element.

Comment 7 errata-xmlrpc 2017-01-04 12:59:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html

Comment 8 Justin Burdine 2017-01-18 02:32:06 UTC
I see this is solved for 5.7, however the original issue was on 5.6.  Is there a solution for customers who are still on 5.6?  are there any plans to release a fix? or is the only path forward to upgrade to 5.7?


Note You need to log in before you can comment on or make changes to this bug.