Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364497 - posix: honour fsync flags in posix_do_zerofill
Summary: posix: honour fsync flags in posix_do_zerofill
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: 3.8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On: 1364449
Blocks: glusterfs-3.8.2
TreeView+ depends on / blocked
 
Reported: 2016-08-05 13:49 UTC by Niels de Vos
Modified: 2016-08-12 09:48 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1364449
Environment:
Last Closed: 2016-08-12 09:48:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-08-05 13:49:41 UTC
+++ This bug was initially created as a clone of Bug #1364449 +++

commit 6d994661db96cad43f26d0d1e2fba31dce9a76f5 introduced fallocate +
    FALLOC_FL_ZERO_RANGE to do posix_do_zerofill but did not do an fsync if
    O_SYNC or O_DSYNC fd flags were set. Prashant Pai pointed out performing
    fallocate(2) does not remove the necessity to do fsyncs if durability is
    desired: http://linux-fsdevel.vger.kernel.narkive.com/bDmrAUlh/fallocate-falloc-fl-punch-hole

--- Additional comment from Vijay Bellur on 2016-08-05 13:30:37 CEST ---

REVIEW: http://review.gluster.org/15100 (posix: honour fsync flags in posix_do_zerofill) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 1 Vijay Bellur 2016-08-05 16:22:10 UTC
REVIEW: http://review.gluster.org/15103 (posix: honour fsync flags in posix_do_zerofill) posted (#1) for review on release-3.8 by Ravishankar N (ravishankar@redhat.com)

Comment 2 Vijay Bellur 2016-08-06 05:40:28 UTC
COMMIT: http://review.gluster.org/15103 committed in release-3.8 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 2c748b731f233588b97d375ce92a5ae56612d764
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Fri Aug 5 11:22:18 2016 +0000

    posix: honour fsync flags in posix_do_zerofill
    
    Backport of http://review.gluster.org/#/c/15100/
    commit fe1054110ac54750ca0333a727d83b14a98e165e introduced fallocate +
    FALLOC_FL_ZERO_RANGE to do posix_do_zerofill but did not do an fsync if
    O_SYNC or O_DSYNC fd flags were set. Prashant Pai pointed out performing
    fallocate(2) does not remove the necessity to do fsyncs if durability is
    desired: http://linux-fsdevel.vger.kernel.narkive.com/bDmrAUlh/fallocate-falloc-fl-punch-hole
    
    So fixed it to honour the fd flags.
    
    Change-Id: I27ae90b429185d0af29a5e632c4a8b242075a899
    BUG: 1364497
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    (cherry picked from commit cf51bc699646359be92969024a52c225e7ee55a1)
    Reviewed-on: http://review.gluster.org/15103
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 3 Niels de Vos 2016-08-12 09:48:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.2, please open a new bug report.

glusterfs-3.8.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000058.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.