Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364495 - systemd could not restart glusterd after /var/run/glusterd.pid disappeared
Summary: systemd could not restart glusterd after /var/run/glusterd.pid disappeared
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: scripts
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1364492
TreeView+ depends on / blocked
 
Reported: 2016-08-05 13:41 UTC by Niels de Vos
Modified: 2018-08-29 03:36 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.1.3 (or later)
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1364492
Environment:
Last Closed: 2018-08-29 03:36:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-08-05 13:41:27 UTC
+++ This bug was initially created as a clone of Bug #1364492 +++

Description of problem:
I'm not sure what caused /var/run/glusterd.pid to be missing, but after an update systemd was unable to start glusterd again. glusterd was running, but a 2nd instance was unable to bind the 24007 port (address already in use).

I was not able to reproduce this when configuring the glusterd.service file as Type=simple and adding the --no-daemon parameter to the commandline.


Version-Release number of selected component (if applicable):
3.8.1 (on Fedora 23/24)

How reproducible:
Have updates installed by ansible, with a restart of the glusterd service after the packages got updated.


Steps to Reproduce:
1. install and configure Gluster, make sure that the glusterd service is running
2. update the packages
3. restart the glusterd service with "systemctl restart glusterd"

Actual results:
glusterd fails to restart

Expected results:
glusterd should have been restarted with the new (updated) binaries

Additional info:

Comment 1 Vijay Bellur 2016-08-05 13:43:10 UTC
REVIEW: http://review.gluster.org/15101 (glusterd: do not fork into the background when systemd is used) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 2 Vijay Bellur 2016-08-05 14:20:21 UTC
REVIEW: http://review.gluster.org/15101 (glusterd: do not fork into the background when systemd is used) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 3 Amar Tumballi 2018-08-29 03:36:12 UTC
This update is done in bulk based on the state of the patch and the time since last activity. If the issue is still seen, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.