Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364423 - [ganesha+gdeploy]: Update client section for different mount options used in nfs-ganesha.
Summary: [ganesha+gdeploy]: Update client section for different mount options used in ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.2.0
Assignee: Sachidananda Urs
QA Contact: Manisha Saini
URL:
Whiteboard:
Depends On:
Blocks: 1351528
TreeView+ depends on / blocked
 
Reported: 2016-08-05 10:21 UTC by Shashank Raj
Modified: 2017-03-23 05:08 UTC (History)
10 users (show)

Fixed In Version: gdeploy-2.0.1-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 05:08:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0482 normal SHIPPED_LIVE Red Hat Gluster Storage 3.2.0 gdeploy bug fix and enhancement update 2017-03-23 09:06:28 UTC

Description Shashank Raj 2016-08-05 10:21:09 UTC
Description of problem:

Update client section for different mount options used in nfs-ganesha.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Update client section for different mount options used in nfs-ganesha.

Additional info:

Comment 2 Niels de Vos 2016-08-05 10:53:54 UTC
What kind of options would you expect to be settable through gdeploy?

I can think of these in the "client {}" block of an export:

 - only allow access from certain clients, based on IP-address, netmask, ...
 - force security settings, like only clients that mount with Kerberos

Comment 3 Shashank Raj 2016-08-05 11:39:56 UTC
I meant the options which a user might want to change when doing a manual mount. 

Options like below:

rw,relatime,vers=4.0,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=10.70.46.206,local_lock=none,addr=10.70.40.192

Comment 4 Sachidananda Urs 2016-08-11 11:39:30 UTC
This will be an enhancement to mount module to include the options.
Currently we only supported vers=? option.

Comment 5 Sachidananda Urs 2016-08-17 12:07:08 UTC
Currently the clients section for nfs, would look like this:

[clients]
action=mount
volname=dhcp37-102.lab.eng.blr.redhat.com:/ganesha
hosts=dhcp37-102.lab.eng.blr.redhat.com
client_mount_points=/mnt/ganesha
fstype=nfs
options=rw,relatime,vers=4.0,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=10.70.46.206,local_lock=none,addr=10.70.40.192


Or

[clients]
action=mount
volname=dhcp37-102.lab.eng.blr.redhat.com:/ganesha
hosts=dhcp37-102.lab.eng.blr.redhat.com
client_mount_points=/mnt/ganesha
fstype=nfs


The `options' variable can be safely omitted, it mounts nfs version 3 with the defaults whatever nfs-ganesha sets.

Comment 10 Sachidananda Urs 2016-09-20 07:13:31 UTC
Rebase fixes the issue.

Comment 15 Manisha Saini 2016-11-22 14:22:18 UTC
Verified this bug on

[root@dhcp47-3 gdeploy]# rpm -qa | grep gdeploy
gdeploy-2.0.1-4.el7rhgs.noarch

[root@dhcp47-3 gdeploy]# rpm -qa | grep ansible
ansible-2.2.0.0-1.el7.noarch

[hosts]
dhcp46-241.lab.eng.blr.redhat.com
dhcp46-219.lab.eng.blr.redhat.com
dhcp47-159.lab.eng.blr.redhat.com
dhcp47-3.lab.eng.blr.redhat.com


[firewalld2:10.70.46.30]
action=add
ports=662/tcp,662/udp,32803/tcp,32769/udp

[clients]
action=mount
volname=10.70.44.153:/ganeshaVol1
hosts=10.70.46.30
client_mount_points=/mnt/ganesha
fstype=nfs
options=rw,relatime,vers=4.0,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=10.70.44.153,local_lock=none,addr=10.70.46.30


As we can change the parameters at mount time with gdeploy,Hence marking this bug as Verified

Comment 17 errata-xmlrpc 2017-03-23 05:08:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2017-0482.html


Note You need to log in before you can comment on or make changes to this bug.