Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364407 - A value input into a service dialog element is not always visible to another dynamic element that is set to auto refresh
Summary: A value input into a service dialog element is not always visible to another ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: GA
: 5.8.0
Assignee: eclarizi
QA Contact: Shveta
URL:
Whiteboard: service:dialog
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-05 09:52 UTC by Peter McGowan
Modified: 2018-02-28 15:29 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-28 15:29:39 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
Service dialog to reproduce the problem (deleted)
2016-08-05 09:52 UTC, Peter McGowan
no flags Details
Automate domain code to reproduce the problem (deleted)
2016-08-05 09:52 UTC, Peter McGowan
no flags Details

Description Peter McGowan 2016-08-05 09:52:04 UTC
Created attachment 1187812 [details]
Service dialog to reproduce the problem

Description of problem:
A value input into a service dialog element should be readable by the method populating another dynamic element using $evm.root['dialog_element_name']. This seems to work fine in the subsequent dynamic element is not set to Auto refresh, and has a Refresh button. If the subsequent dynamic element(s) are set to Auto refresh however, the original element's return value is only intermittently available.

Version-Release number of selected component (if applicable):
5.6.0.13

How reproducible:
Most times

Steps to Reproduce:
1. Import the attached dynamic_dialog_bug_reproducer_domain_export.zip automate domain and dynamic_dialog_bug_reproducer_dialog_export.yml dialog. 
2. Run the resulting service dialog from a button on a VM. Toggle the radio button repeatedly forcing the dynamic methods to refresh.


Actual results:
Intermittently you'll see the correct value displayed in either of the 'dynamic_1' or 'dynamic_2' elements, but most times you'll just see '<None>'

Expected results:
The return value from the radio button should be displayed in each of the subsequent elements.


Additional info:
This example also reproduces https://bugzilla.redhat.com/show_bug.cgi?id=1354054 fairly reliably. I've applied https://github.com/ManageIQ/manageiq/commit/cbb5661645090d377341d72567697b6ee1d1784a and https://github.com/ManageIQ/manageiq/commit/a1656fce7e861a92a671390648535533d753f6a6 to  patch the Errno::ECONNREFUSED errors, but the problem still remains.

Comment 2 Peter McGowan 2016-08-05 09:52:45 UTC
Created attachment 1187813 [details]
Automate domain code to reproduce the problem

Comment 3 Greg McCullough 2016-08-08 17:47:10 UTC
Erik - Let's discuss possible solutions.

Comment 4 Dave Johnson 2016-08-12 15:48:25 UTC
A workaround does exist for this one, a refresh button can be added to the dialog to update the values in the dropdown

Comment 8 eclarizi 2017-04-26 15:41:01 UTC
I am unable to reproduce this issue in the latest 5.7.z build. I think that the work that was done revolving around the cascading auto-refreshes most likely fixed this issue.

Comment 11 Shveta 2017-07-26 18:49:16 UTC
Fixed .
Verified in 5.8.1.4.20170721182148_8ed7c73


Note You need to log in before you can comment on or make changes to this bug.