Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364393 - Network Manager does not set hostname from DHCP
Summary: Network Manager does not set hostname from DHCP
Keywords:
Status: CLOSED DUPLICATE of bug 1356015
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Rashid Khan
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-05 09:14 UTC by Otto Sabart
Modified: 2018-02-01 10:11 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-06 08:31:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1540913 None None None 2019-04-07 18:41:08 UTC

Internal Links: 1540913

Description Otto Sabart 2016-08-05 09:14:18 UTC
Description of problem:
After provision of latest RHEL-7.3-20160729.1 the Network Manager does not set
hostname which gets from the DHCP server. When I restart NetworkManager.service, it sets
the hostname correctly and everything is back to normal.

Version-Release number of selected component (if applicable):
RHEL: RHEL-7.3-20160729.1 (Red Hat Enterprise Linux Server release 7.3 Beta (Maipo))

$ uname -a
Linux omg 3.10.0-481.el7.x86_64 #1 SMP Wed Jul 27 18:24:27 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux

$ yum info NetworkManager
Installed Packages
Name        : NetworkManager
Arch        : x86_64
Epoch       : 1
Version     : 1.4.0
Release     : 0.4.git20160727.9446481f.el7
Repo        : installed
From repo   : beaker-Server

How reproducible:
80%

Steps to Reproduce:
1. provision of RHEL-7.3-20160729.1
2. reboot
3. $ hostname

Actual results:
$ hostname
localhost.localdomain

Expected results:
It will set the hostname from DHCP server correctly.
$ hostname
blesk-01.*...*.redhat.com

Additional info:
- I do not know why is this happening but on RHEL7.2 everything works fine.
- I can provision and prepare machine for you. Just let me know.

Comment 4 Beniamino Galvani 2016-08-05 16:05:40 UTC
(In reply to Otto Sabart from comment #0)

> - I can provision and prepare machine for you. Just let me know.

That would be helpful, thanks.

Comment 5 Beniamino Galvani 2016-08-06 08:31:52 UTC

*** This bug has been marked as a duplicate of bug 1356015 ***


Note You need to log in before you can comment on or make changes to this bug.