Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364287 - KAlarm running under Gnome 3 session
Summary: KAlarm running under Gnome 3 session
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepim
Version: 24
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-05 00:47 UTC by David H. Gutteridge
Modified: 2016-08-09 20:46 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 20:30:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 357653 None None None 2016-08-09 20:30:43 UTC

Description David H. Gutteridge 2016-08-05 00:47:33 UTC
Description of problem:

When Gnome 3 and Plasma-Workspace are both installed, KAlarm starts under a Gnome session. (I was inspired to report this by bug 1361765, which was also affecting me.) (BTW, I couldn't find a package named "kalarm" to choose from on the component list above.)

Version-Release number of selected component (if applicable):
kalarm-16.04.3-1.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Log into a Gnome session.
2. Note that KAlarm has started.

Additional info:

I looked at bug 1361765 for hints on how to deal with this, but the file /etc/xdg/autostart/kalarm.autostart.desktop doesn't have the same setting. I also tried changing settings in KAlarm's preferences panel, e.g. un-checking "start at login", but that doesn't seem to have any effect. It's relatively recently that KAlarm has started behaving like this.

Comment 1 Rex Dieter 2016-08-09 20:30:44 UTC
See also,
https://bugs.kde.org/show_bug.cgi?id=366562
https://bugs.kde.org/show_bug.cgi?id=357653

just found these, looks like the behavior here is intentional... If you do not want it to autostart, configure it to do so in it's settings.

Comment 2 David H. Gutteridge 2016-08-09 20:46:17 UTC
Sure, but in https://bugs.kde.org/show_bug.cgi?id=366562 it's stated "But it shouldn't start if it has never been used, or if the user has explicitly disabled start-at-login for it." I have explicitly disabled start-at-login in KAlarm's settings, and it still starts every time. Anyway, I'll jump on that bug upstream.


Note You need to log in before you can comment on or make changes to this bug.