Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364204 - [DOCS] Disconnect Install steps missing S2I steps. [NEEDINFO]
Summary: [DOCS] Disconnect Install steps missing S2I steps.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: brice
QA Contact: Johnny Liu
Vikram Goyal
URL:
Whiteboard:
: 1305675 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 17:32 UTC by Ryan Howe
Modified: 2016-08-26 04:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-26 04:30:50 UTC
bfallonf: needinfo? (rhowe)


Attachments (Terms of Use)

Description Ryan Howe 2016-08-04 17:32:31 UTC
Document URL: https://docs.openshift.com/enterprise/latest/install_config/install/disconnected_install.html#disconnected-re-tagging-s2i-builder-images

Section Number and Name: 
  
   disconnected-re-tagging-s2i-builder-images

Describe the issue: 

- Steps on pushing the images to the registry are missing. 
      -Template try pulling images base on tags which are not set when following steps in docs

EX: # docker push $REGISTRY:5000/openshift/<IMAGE>:<TAG> 

- Steps on modifying imagestream to point to the correct registry

EX: # sed 's|registry.access.redhat.com.*\/|myregistyr.com\/openshift\/|g' /usr/share/openshift/examples/xpaas-streams/jboss-image-streams.json > new-jboss-image-streams.json
    # oc create -n openshift -f /usr/share/openshift/examples/new-xpaas-streams

- Modifying templates to ref the correct tag are missing (this will not be needed if we pull the right images with tag and then push the images with the tags). List needed of what images and tags are needed
 
- The steps on syncing the images only has one pulling the latest. Since tags are referenced in templates, users must make sure they pull the images with the correct tag and push it to the internal registry with the correct tag. 

https://docs.openshift.com/enterprise/latest/install_config/install/disconnected_install.html#disconnected-syncing-images

Additional information: 


# oc get template -n openshift eap64-basic-s2i -o yaml

    strategy:
      sourceStrategy:
        forcePull: true
        from:
          kind: ImageStreamTag
          name: jboss-eap64-openshift:1.2
          namespace: ${IMAGE_STREAM_NAMESPACE}

The tag is hardcoded in some of the templates

Comment 1 brice 2016-08-12 04:47:47 UTC
(In reply to Ryan Howe from comment #0)

Ryan, some questions inline before I start documenting this:

> Document URL:
> https://docs.openshift.com/enterprise/latest/install_config/install/
> disconnected_install.html#disconnected-re-tagging-s2i-builder-images
> 
> Section Number and Name: 
>   
>    disconnected-re-tagging-s2i-builder-images
> 
> Describe the issue: 
> 
> - Steps on pushing the images to the registry are missing. 
>       -Template try pulling images base on tags which are not set when
> following steps in docs
> 
> EX: # docker push $REGISTRY:5000/openshift/<IMAGE>:<TAG> 

This is in this section:

https://docs.openshift.com/enterprise/3.2/install_config/install/disconnected_install.html#disconnected-loading-the-docker-images

Are you saying this should be included somewhere else? Earlier in the docs? i agree that is could be worded different so the reader knows we're building up to it, rather than it being in the same section.

> 
> - Steps on modifying imagestream to point to the correct registry
> 
> EX: # sed 's|registry.access.redhat.com.*\/|myregistyr.com\/openshift\/|g'
> /usr/share/openshift/examples/xpaas-streams/jboss-image-streams.json >
> new-jboss-image-streams.json
>     # oc create -n openshift -f
> /usr/share/openshift/examples/new-xpaas-streams

For the above, the "oc create" command is there: 
https://docs.openshift.com/enterprise/3.2/install_config/install/disconnected_install.html#disconnected-editing-the-image-stream-definitions

but the first part is missing. Where are you saying that should be included? Inbetween step 2 and 3?

> 
> - Modifying templates to ref the correct tag are missing (this will not be
> needed if we pull the right images with tag and then push the images with
> the tags). List needed of what images and tags are needed

I'm not sure which are missing. Do you know which are missing?

>  
> - The steps on syncing the images only has one pulling the latest. Since
> tags are referenced in templates, users must make sure they pull the images
> with the correct tag and push it to the internal registry with the correct
> tag. 
> 
> https://docs.openshift.com/enterprise/latest/install_config/install/
> disconnected_install.html#disconnected-syncing-images
> 
> Additional information: 
> 
> 
> # oc get template -n openshift eap64-basic-s2i -o yaml
> 
>     strategy:
>       sourceStrategy:
>         forcePull: true
>         from:
>           kind: ImageStreamTag
>           name: jboss-eap64-openshift:1.2
>           namespace: ${IMAGE_STREAM_NAMESPACE}
> 
> The tag is hardcoded in some of the templates

To clarify, I should make the images less version-specific? So maybe:

docker pull \
registry.access.redhat.com/openshift3/ose-haproxy-router:<version_number>


Any more info is great. Thanks!

Comment 2 Ryan Howe 2016-08-16 22:52:43 UTC
I see now that we do have docs on changing the docker dockerImageRepository for the image streams. 


The steps missing are with the images being pushed to the internal registry are not tagged with all the correct tags one would get from our registry. With out these some quick-start templates will fail. 

Example: 

In the template for jws30-tomcat7-basic-s2i it references image stream image with a tag of 1.2 
 
# oc get template -n openshift jws30-tomcat7-basic-s2i -o yaml

 kind: ImageStreamTag
          name: jboss-webserver30-tomcat7-openshift:1.2


The image stream has this tag but the documentation skips over the steps that would be needed to make sure the right image is pulled with the correct tag and then that image is tagged and pushed to the internal registry. 

For this imagestream that is references we need to make sure we pull and push the following: 

# docker pull registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat7-openshift:latest
# docker pull registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat7-openshift:1.1

The we would need to save, import, then retag: 

# docker tag egistry.access.redhat.com/jboss-webserver-3/webserver30-tomcat7-openshift:1.1 $REGISTRY:5000/openshift/webserver30-tomcat7-openshift:1.1
# docker tag egistry.access.redhat.com/jboss-webserver-3/webserver30-tomcat7-openshift:latest $REGISTRY:5000/openshift/webserver30-tomcat7-openshift:1.2
# docker tag egistry.access.redhat.com/jboss-webserver-3/webserver30-tomcat7-openshift:latest $REGISTRY:5000/openshift/webserver30-tomcat7-openshift:latest

Then push the 3 images to the registry. 

The steps above would need to be done for the following images:
 
jboss-eap70-openshift
jboss-amq-62
jboss-datagrid65-openshift
jboss-decisionserver62-openshift
jboss-eap64-openshift
jboss-eap70-openshift 
jboss-webserver30-tomcat7-openshift 
jboss-webserver30-tomcat8-openshift  
mongodb
mysql
nodejs
perl 
php 
postgresql 
python 
redhat-sso70-openshift
ruby 

Tags can be seen by running `oc describe is -n openshift` on an env that has the imagestreams created.

Comment 3 brice 2016-08-17 03:44:39 UTC
Ryan,

PR made for this:

https://github.com/openshift/openshift-docs/pull/2668

Thanks for the extra info. I understand you now. I've played around with the topic much like you're asking and using the Tomcat image as an example, I've fixed the tag info as suggested.

Can I please get an ack this is fulfilling what you're asking for? Once that's done, I'll try get this to go through QE as it's a reasonably big change, I think.

Thanks!

Comment 4 Ryan Howe 2016-08-19 17:56:06 UTC
In relation to the tags we might add that the quickstart templates added will not work out of the box. As they require certain images stream tags, as well as access to external repos like github, maven, etc...

Comment 5 brice 2016-08-22 00:22:29 UTC
*** Bug 1305675 has been marked as a duplicate of this bug. ***

Comment 6 brice 2016-08-22 01:09:50 UTC
Ryan,

Thanks for the review. I've made some changes. Can I get a final ack this fulfills this BZ now? Thanks!

Comment 7 openshift-github-bot 2016-08-23 04:39:50 UTC
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/f7e2bb7e986067af832c8a8154245705d3d3289c
Merge pull request #2668 from bfallonf/bz1364204

Bug 1364204 disconnected image and tag fix


Note You need to log in before you can comment on or make changes to this bug.