Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364155 - UI: "Perform SmartState Analysis" option is not available under "Configuration" tab in RHEVM35
Summary: UI: "Perform SmartState Analysis" option is not available under "Configuratio...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Harpreet Kataria
QA Contact: Satyajit Bulage
URL:
Whiteboard: ui:smartstate
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 14:54 UTC by Satyajit Bulage
Modified: 2017-08-21 13:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-21 13:02:30 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing actual results (deleted)
2016-08-04 14:54 UTC, Satyajit Bulage
no flags Details

Description Satyajit Bulage 2016-08-04 14:54:26 UTC
Created attachment 1187557 [details]
Screenshot showing actual results

Description of problem: SmartState Analysis option is not available under "Configuration" tab on summary page of VM.

Version-Release number of selected component (if applicable):5.6.1.0.20160726144018_810a94f 


How reproducible:100%


Steps to Reproduce:
1.Configure Appliance and attach LUN to it.
2.Goto Compute --> Infrastructure --> Virtual Machines 
3.On Virtual Machines summary page Click on Configuration --> Perform SmartState Analysis on VM

Actual results:
Perform SmartState Analysis Option is not available.

Expected results:
Perform SmartState Analysis Option should be available.

Additional info:

Comment 3 Harpreet Kataria 2016-08-11 14:00:27 UTC
Satyajit,

I looked into this issue and found that we do support Smartstate Analysis on RHEVM VMs but the button is only visible on summary screen if specific record type supports that task and has met certain conditions, one of the reasons for button not being available could be "No active SmartProxies found to analyze this VM".
Another one of the reason i found that the button might not be available is:

VMs must be scanned from an EVM server whose host is attached to the same
  storage as the VM unless overridden via SmartProxy affinity.
  Please verify that:
  1) Direct LUNs are attached to ManageIQ appliance
  2) Management Relationship is set for the ManageIQ appliance

Can you check your environment, for the above.

~Harpreet

Comment 4 Satyajit Bulage 2016-08-16 05:47:53 UTC
Hello Harpreet,

Yes, I performed every steps i.e. adding Direct LUNs and set the appliance for Management Relationship. Also, I enabled SmartProxy for an appliance.

Thanks,
Satyajit Bulage.

Comment 5 Chris Pelland 2017-08-21 13:02:30 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.