Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364091 - Installpackage autocomplete function lists packages which can not be installed
Summary: Installpackage autocomplete function lists packages which can not be installed
Keywords:
Status: NEW
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 2.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomáš Kašpárek
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 13:04 UTC by Ondrej Gajdusek
Modified: 2017-12-21 14:54 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Ondrej Gajdusek 2016-08-04 13:04:31 UTC
Description of problem:
The function complete_system_installpackage ignores the specified systems in arguments. Consequently the function lists all the packages in all channels, instead of listing packages that are included in the channel to which the system mentioned in the arguments is subscribed.

Version-Release number of selected component (if applicable):spacecmd-2.6.2-1.el6.noarch


How reproducible: always


Steps to Reproduce:
1.open spacecmd on server
2.and type "system_installpackage ibm-x3650m4-03-vm14.lab.eng.brq.redhat.com google-chrome-stable -s 8h"

Actual results:
system_installpackage ibm-x3650m4-03-vm14.lab.eng.brq.redhat.com <autocomplete used here>google-chrome-stable -s 8h
WARNING: No packages to install

Expected results:
system_installpackage ibm-x3650m4-03-vm14.lab.eng.brq.redhat.com <autocomplete must not list anything, because in channels to which is system subscribed does not contain any package>

Additional info:

Comment 2 Ondrej Gajdusek 2017-12-21 14:54:13 UTC
Resetting to default assignee as I am no longer part of the development team.


Note You need to log in before you can comment on or make changes to this bug.