Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364054 - [Beaker][WebUI] Unable to waive results on jobs that I don't own but the jobs are in a group
Summary: [Beaker][WebUI] Unable to waive results on jobs that I don't own but the jobs...
Keywords:
Status: NEW
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 11:57 UTC by Jeff Burke
Modified: 2018-11-09 23:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)
Picture of the failure. In the back ground you can see I am logged in as well (deleted)
2016-08-04 11:57 UTC, Jeff Burke
no flags Details

Description Jeff Burke 2016-08-04 11:57:00 UTC
Created attachment 1187451 [details]
Picture of the failure. In the back ground you can see I am logged in as well

Description of problem:
 While reviewing results for a kerneltier1 testing. Testing started by Petr Holasek, but the XML has group="kernel-mtr" which I am a member of. We see "know" issues. In order to reduce the noise on the matrix view. We will waive the results. When I tried to waive the results I received this error : "UNAUTHORIZED: Authenticated user required". I am logged in.

Comment 1 Jeff Burke 2016-08-04 11:58:44 UTC
Update. Even thought it gave me the error. It did actually allow me to waive the result.

Comment 2 Dan Callaghan 2016-08-14 04:59:27 UTC
Jeff, is it possible that you had opened the page while you were logged in, and then only hit Waive some time later after your Beaker session was expired? Or possibly logged out of Beaker in a different window? I think that would match the behaviour you are describing.

Can you reproduce the problem, if you log in afresh and visit a group job and waive it? Does it give the same error or is it working?

We have a longstanding issue with the AJAX requests where they cannot magically authenticate you if you are logged out (or your session is expired) when you try to make the AJAX request. Basically bug 1124139.


Note You need to log in before you can comment on or make changes to this bug.