Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364053 - [RFE] virt-v2v traces should go only to stdout or stderr, not both
Summary: [RFE] virt-v2v traces should go only to stdout or stderr, not both
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 11:47 UTC by Tomáš Golembiovský
Modified: 2016-08-09 07:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 07:40:37 UTC


Attachments (Terms of Use)

Description Tomáš Golembiovský 2016-08-04 11:47:37 UTC
Currently the virt-v2v tracing is inconsistent. Some traces/debug messages end up on stdout and some on stderr. To obtain useful log one must merge stdout and stderr streams and store both. While it is generally not a problem, this may complicate things when virt-v2v is not run manualy but is used inside some other tool.

Also since the tracing is rather aggressive it can make it difficult to find the error message among the debug messages in case of an error. It might be preferable to put all the traces to stdout and keep stderr for error reporting only. This is again mainly to simplify situation when virt-v2v is used in some other tool.

Comment 1 Richard W.M. Jones 2016-08-04 11:58:03 UTC
This is fixed upstream - please check the latest version.

Comment 2 Tomáš Golembiovský 2016-08-09 07:40:37 UTC
Confirmed. Closing the bug.


Note You need to log in before you can comment on or make changes to this bug.