Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364049 - Puppet report page shows error
Summary: Puppet report page shows error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Reporting
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: 6.2
Assignee: Marek Hulan
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 11:38 UTC by Alexander Braverman
Modified: 2018-12-06 20:45 UTC (History)
4 users (show)

Fixed In Version: foreman-1.11.0.51-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-16 07:11:46 UTC


Attachments (Terms of Use)
Screenshot of the error (deleted)
2016-08-04 11:38 UTC, Alexander Braverman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1615 normal SHIPPED_LIVE Satellite 6.2.1 bug fix update 2016-08-16 11:09:48 UTC
Foreman Issue Tracker 14154 None None None 2016-08-04 12:01:58 UTC

Description Alexander Braverman 2016-08-04 11:38:02 UTC
Created attachment 1187447 [details]
Screenshot of the error

Description of problem:
When I try to view a puppet report I get an error instead.

Version-Release number of selected component (if applicable):
6.2.0 GA

How reproducible:
Always

Steps to Reproduce:
1. Have a host managed by satellite with puppet agent configured and failing
2. Go to Puppet reports in Satellite: https://satellite.com/hosts/HOST_FQDN/config_reports
3. Open failed report

Actual results:
Oops, we're sorry but something went wrong no implicit conversion of true into Hash

Expected results:
View of the puppet report on page: https://satellite.com/config_reports/REPORT_NUMBER

Additional info:
The host has the same puppet version as master.

Comment 1 Ohad Levy 2016-08-04 11:39:18 UTC
Connecting redmine issue http://projects.theforeman.org/issues/14154 from this bug

Comment 3 Bryan Kearney 2016-08-04 14:17:16 UTC
Upstream bug assigned to mhulan@redhat.com

Comment 4 Bryan Kearney 2016-08-04 14:17:19 UTC
Upstream bug component is Reporting

Comment 5 Bryan Kearney 2016-08-04 14:17:21 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14154 has been closed

Comment 9 Ohad Levy 2016-08-08 13:25:30 UTC
this has not been merged yet, your configuration report does not include the relevant condition (it requires the time in which the report was created vs the time in which the report was accepted - usually indicating a time / clock drift).

Comment 10 jcallaha 2016-08-12 21:48:20 UTC
Verified in Satellite 6.2 Snap 1.2

Followed same steps as above, but used puppetlabs/ntp module to stop autosync with ntp server. Then remote execution to adjust the system time a day forward. Page then shows an error that the host seems to be adrift. See attached.

Comment 12 errata-xmlrpc 2016-08-16 07:11:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1615


Note You need to log in before you can comment on or make changes to this bug.