Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364045 - CLI - Deploying application with infinispan-cli-server dependency to the EAP server results in error
Summary: CLI - Deploying application with infinispan-cli-server dependency to the EAP ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: Library
Version: 6.6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 6.6.1
Assignee: Sebastian Łaskawiec
QA Contact: Martin Gencur
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 11:31 UTC by Roman Macor
Modified: 2016-08-09 11:53 UTC (History)
3 users (show)

Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 11:53:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Roman Macor 2016-08-04 11:31:25 UTC
Steps to reproduce:
- add infinispan-cli-server dependency to cartmart-tx quickstart:

   <dependency>
      <groupId>org.infinispan</groupId>
      <artifactId>infinispan-cli-server</artifactId>
      <version>6.4.1.ER1-redhat-1</version>
      <scope>runtime</scope>
   </dependency>
 - deploy the application to the server
 - start the server

This results in:

13:07:46,240 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC000001: Failed to start service jboss.deployment.unit."jboss-carmart-tx.war".POST_MODULE: org.jboss.msc.service.StartException in service jboss.deployment.unit."jboss-carmart-tx.war".POST_MODULE: JBAS018733: Failed to process phase POST_MODULE of deployment "jboss-carmart-tx.war"
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:166) [jboss-as-server-7.5.9.Final-redhat-2.jar:7.5.9.Final-redhat-2]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1980) [jboss-msc-1.1.6.Final-redhat-1.jar:1.1.6.Final-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1913) [jboss-msc-1.1.6.Final-redhat-1.jar:1.1.6.Final-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_76-ea]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_76-ea]
	at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_76-ea]
Caused by: java.lang.ExceptionInInitializerError
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) [rt.jar:1.8.0_76-ea]
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) [rt.jar:1.8.0_76-ea]
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) [rt.jar:1.8.0_76-ea]
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423) [rt.jar:1.8.0_76-ea]
	at java.lang.Class.newInstance(Class.java:442) [rt.jar:1.8.0_76-ea]
	at org.jboss.as.weld.deployment.WeldPortableExtensions.tryRegisterExtension(WeldPortableExtensions.java:54)
	at org.jboss.as.weld.deployment.processors.WeldPortableExtensionProcessor.loadAttachments(WeldPortableExtensionProcessor.java:119)
	at org.jboss.as.weld.deployment.processors.WeldPortableExtensionProcessor.deploy(WeldPortableExtensionProcessor.java:79)
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:159) [jboss-as-server-7.5.9.Final-redhat-2.jar:7.5.9.Final-redhat-2]
	... 5 more
Caused by: java.lang.IllegalArgumentException: Logger implementation class org.infinispan.cdi.util.logging.EmbeddedLog_$logger has no matching constructor
	at org.jboss.logging.Logger$1.run(Logger.java:2260)
	at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.8.0_76-ea]
	at org.jboss.logging.Logger.getMessageLogger(Logger.java:2227)
	at org.jboss.logging.Logger.getMessageLogger(Logger.java:2214)
	at org.infinispan.commons.logging.LogFactory.getLog(LogFactory.java:19)
	at org.infinispan.cdi.InfinispanExtensionEmbedded.<clinit>(InfinispanExtensionEmbedded.java:46)
	... 14 more

13:07:46,261 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) JBAS014612: Operation ("deploy") failed - address: ([("deployment" => "jboss-carmart-tx.war")]) - failure description: {"JBAS014671: Failed services" => {"jboss.deployment.unit.\"jboss-carmart-tx.war\".POST_MODULE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"jboss-carmart-tx.war\".POST_MODULE: JBAS018733: Failed to process phase POST_MODULE of deployment \"jboss-carmart-tx.war\"
    Caused by: java.lang.ExceptionInInitializerError
    Caused by: java.lang.IllegalArgumentException: Logger implementation class org.infinispan.cdi.util.logging.EmbeddedLog_$logger has no matching constructor"}}
13:07:46,318 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 28) JBAS015859: Deployed "jboss-carmart-tx.war" (runtime-name : "jboss-carmart-tx.war")
13:07:46,320 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014777:   Services which failed to start:      service jboss.deployment.unit."jboss-carmart-tx.war".POST_MODULE: org.jboss.msc.service.StartException in service jboss.deployment.unit."jboss-carmart-tx.war".POST_MODULE: JBAS018733: Failed to process phase POST_MODULE of deployment "jboss-carmart-tx.war"

13:07:46,462 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management
13:07:46,462 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
13:07:46,463 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss EAP 6.4.9.GA (AS 7.5.9.Final-redhat-2) started (with errors) in 5626ms - Started 166 of 205 services (1 services failed or missing dependencies, 59 services are lazy, passive or on-demand)


Note You need to log in before you can comment on or make changes to this bug.