Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364024 - SELinux prevents CDS and HA proxy instances from being added (RHEL 6 only)
Summary: SELinux prevents CDS and HA proxy instances from being added (RHEL 6 only)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Patrick Creech
QA Contact: Vratislav Hutsky
URL:
Whiteboard:
Depends On:
Blocks: 1308349
TreeView+ depends on / blocked
 
Reported: 2016-08-04 10:13 UTC by Radek Bíba
Modified: 2017-03-01 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1363978
Environment:
Last Closed: 2017-03-01 22:12:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0367 normal SHIPPED_LIVE Red Hat Update Infrastructure 3.0 Release 2017-03-02 03:05:22 UTC

Description Radek Bíba 2016-08-04 10:13:08 UTC
+++ This bug was initially created as a clone of Bug #1363978 +++

Description of problem:
A new CDS is added with an error. Further actions in rhui-manager are possible, though.

Version-Release number of selected component (if applicable):
RHEL6 iso 20160727 on NFS

How reproducible:
always

Steps to Reproduce:
1. add a new CDS

Actual results:
Similar to https://bugzilla.redhat.com/attachment.cgi?id=1187393 (attached to bug 1363978) but the error occurs earlier in the process:

sudo() received nonzero return code 1 while executing!

Requested: cp -r /var/lib/puppet/ssl/certificate_requests/cds01.eu-west-1.compute.internal.pem /home/ec2-user/cds01.eu-west-1.compute.internal.pem
Executed: sudo -S -p 'sudo password:'  /bin/bash -l -c "cp -r /var/lib/puppet/ssl/certificate_requests/cds01.eu-west-1.compute.internal.pem /home/ec2-user/cds01.eu-west-1.compute.internal.pem"

============================================================================== Standard output ==============================================================================

cp: cannot stat `/var/lib/puppet/ssl/certificate_requests/cds01.eu-west-1.compute.internal.pem': No such file or directory

=============================================================================================================================================================================

Expected results:
No error

Comment 1 Radek Bíba 2016-08-04 10:23:38 UTC
I might add that the /var/lib/puppet/ssl/certificate_requests/ directory is empty. No other .pem file that could/should be used instead is in it.

Comment 3 Radek Bíba 2016-08-05 06:59:27 UTC
The same problem occurs while adding a new HA proxy:

sudo() received nonzero return code 1 while executing!

Requested: cp -r /var/lib/puppet/ssl/certificate_requests/hap01.eu-west-1.compute.internal.pem /home/ec2-user/hap01.eu-west-1.compute.internal.pem
Executed: sudo -S -p 'sudo password:'  /bin/bash -l -c "cp -r /var/lib/puppet/ssl/certificate_requests/hap01.eu-west-1.compute.internal.pem /home/ec2-user/hap01.eu-west-1.compute.internal.pem"

============================================================================== Standard output ==============================================================================

cp: cannot stat `/var/lib/puppet/ssl/certificate_requests/hap01.eu-west-1.compute.internal.pem': No such file or directory

=============================================================================================================================================================================

Comment 4 Radek Bíba 2016-08-08 11:26:33 UTC
FWIW, on the CDS:

# locate cds01.eu-west-1.compute.internal.pem
/var/lib/puppet/ssl/private_keys/cds01.eu-west-1.compute.internal.pem
/var/lib/puppet/ssl/public_keys/cds01.eu-west-1.compute.internal.pem

Not sure which one (if either of them) was supposed to be in /var/lib/puppet/ssl/certificate_requests.

Comment 6 Irina Gulina 2016-09-09 13:45:16 UTC
Reproduced on RHEL6 NFS and Gluster 20160830

Comment 7 Radek Bíba 2016-09-22 10:19:29 UTC
Everything works fine in Enforcing mode with RHUI-3.0-RHEL-6-20160921.n.0. Thanks Patrick!

Comment 8 errata-xmlrpc 2017-03-01 22:12:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0367


Note You need to log in before you can comment on or make changes to this bug.