Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1364016 - can't start containers with 1.12
Summary: can't start containers with 1.12
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: docker
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio Murdaca
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 09:36 UTC by Tomas Tomecek
Modified: 2016-08-19 12:57 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-19 12:57:16 UTC


Attachments (Terms of Use)

Description Tomas Tomecek 2016-08-04 09:36:12 UTC
Unfortunately nor overlay nor devicemapper are working for me:

$ docker run -ti fedora bash
docker: Error response from daemon: error creating overlay mount to /var/lib/docker/overlay/be6795cd0eddccaa1ea8789a92a3342a888fb100d60e08f5750bc307576a1d0e-init/merged: invalid argument.


$ docker run -ti fedora bash
(waiting a couple minutes)
An error occurred trying to connect: http: server closed connection


I checked logs and there's nothing interesting there. Let me know how can I help further.


Version-Release number of selected component (if applicable):
Linux oat 4.6.4-301.fc24.x86_64 #1 SMP Tue Jul 12 11:50:00 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
docker-1.12.0-6.gitad4812e.fc26.x86_64

Comment 1 Daniel Walsh 2016-08-04 09:48:03 UTC
I think we are covering these issues in a different bug

*** This bug has been marked as a duplicate of bug 1362623 ***

Comment 2 Tomas Tomecek 2016-08-04 13:30:52 UTC
To me this seems it's something different, this is about graph backends, not shim/containerd binary. But if you track all issues in a single bug, I'm fine with that.

Since this is rawhide and I haven't rebooted in a while I assume that full-blown update & reboot could make an impact.

In a meanwhile, I downgraded to 1.11.

Comment 3 Daniel Walsh 2016-08-04 14:32:33 UTC
Good point. Latest docker-1.12 is working for me.  Although I had to fix the SELinux issue in the other bug.

Comment 4 Daniel Walsh 2016-08-04 14:33:17 UTC
Antonio can you check if this works on a fresh install?  When we have the other fix.

Comment 5 Antonio Murdaca 2016-08-04 14:39:52 UTC
Yes, I'm investigating an upgrade issue though

Comment 6 Tomas Tomecek 2016-08-19 12:57:16 UTC
latest 1.12 in rawhide works for me, so closing this


Note You need to log in before you can comment on or make changes to this bug.