Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363979 - [graphics] vertical synchronization problem when moving windows
Summary: [graphics] vertical synchronization problem when moving windows
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-intel
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 08:24 UTC by Tomas Hudziec
Modified: 2017-06-20 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-20 16:30:27 UTC


Attachments (Terms of Use)
video of jagged window (deleted)
2016-08-04 08:24 UTC, Tomas Hudziec
no flags Details

Description Tomas Hudziec 2016-08-04 08:24:50 UTC
Created attachment 1187392 [details]
video of jagged window

Description of problem:
When moving window with mouse, some part of window is jagged.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.99.917-20.20151206.el7.x86_64
kernel-3.10.0-481.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. obtain external monitor and connect it to the laptop Lenovo T440s
2. set up displays as extended desktop
3. open window and move it across the displays

Actual results:
There is a jag on moving window.

Expected results:
Window move is smooth.

Additional info:
This bug is most noticeable with tall and thin window, and on the secondary screen, as shown on attached video.

Comment 1 Tomas Hudziec 2016-08-04 08:48:33 UTC
Probably it is problem with vertical synchronization.

Comment 3 Tomas Hudziec 2016-08-23 12:30:20 UTC
Happens also with graphics card NVIDIA Corporation GK107GL [Quadro K600] [10de:0ffa] ; driver xorg-x11-drv-nouveau-1.0.11-3.el7.x86_64 ; kernel-3.10.0-493.el7.x86_64.

Comment 4 Tomas Hudziec 2016-09-07 12:03:27 UTC
Occurs also on NVIDIA Corporation GM206 [GeForce GTX 960] [10de:1401] ; xorg-x11-drv-nouveau-1.0.11-4.el7.x86_64 ; kernel-3.10.0-501.el7.x86_64.

Comment 6 Tomas Pelka 2017-06-20 16:30:27 UTC
works for me with el7.4


Note You need to log in before you can comment on or make changes to this bug.