Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363965 - geo-replication *changes.log does not respect the log-level configured
Summary: geo-replication *changes.log does not respect the log-level configured
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: All
OS: All
high
high
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On: 1363729
Blocks: 1374606 1374608 1374610
TreeView+ depends on / blocked
 
Reported: 2016-08-04 07:27 UTC by Aravinda VK
Modified: 2017-03-06 17:21 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1363729
: 1374606 1374608 1374610 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:21:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-08-04 07:27:46 UTC
+++ This bug was initially created as a clone of Bug #1363729 +++

Description of problem:

Geo-replication *changes.log does not respect the log-level configured. Always logs the trace &  debug logs regardless of the log-level configured. 


Version-Release number of selected component (if applicable):

How reproducible:

Always

Steps to Reproduce:

1. Setup geo-replication session 
2. check the *changes.log under /var/log/glusterfs/geo-replication/<volname>


Actual results:

*changes.log logs the debug and trace logs even the log-level is info

Expected results:

*changes.log should log messages with respect to the log-level set

Additional info:

--- Additional comment from Aravinda VK on 2016-08-03 08:48:17 EDT ---

As a workaround(If manually editing files are ok)

Edit /usr/libexec/glusterfs/python/syncdaemon/master.py in all master nodes. Search for CHANGELOG_LOG_LEVEL. Change the value from 9 to 7.

After changes are complete, Stop and Start the Geo-rep session. Changes log should start logging in INFO mode.

Patch sent to upstream to fix the issue.
http://review.gluster.org/15078

Comment 1 Vijay Bellur 2016-08-04 07:31:31 UTC
REVIEW: http://review.gluster.org/15078 (geo-rep: Use configured log_level for libgfchangelog logs) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Vijay Bellur 2016-08-08 07:10:39 UTC
REVIEW: http://review.gluster.org/15078 (geo-rep: Use configured log_level for libgfchangelog logs) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Vijay Bellur 2016-08-09 08:56:09 UTC
REVIEW: http://review.gluster.org/15078 (geo-rep: Use configured log_level for libgfchangelog logs) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 4 Vijay Bellur 2016-08-09 10:54:55 UTC
REVIEW: http://review.gluster.org/15078 (geo-rep: Use configured log_level for libgfchangelog logs) posted (#5) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 5 Worker Ant 2016-08-22 05:21:31 UTC
REVIEW: http://review.gluster.org/15078 (geo-rep: Use configured log_level for libgfchangelog logs) posted (#6) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 6 Worker Ant 2016-08-25 08:17:26 UTC
REVIEW: http://review.gluster.org/15078 (geo-rep: Use configured log_level for libgfchangelog logs) posted (#7) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 7 Worker Ant 2016-09-08 06:20:38 UTC
REVIEW: http://review.gluster.org/15078 (geo-rep: Use configured log_level for libgfchangelog logs) posted (#8) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 8 Worker Ant 2016-09-09 07:23:33 UTC
COMMIT: http://review.gluster.org/15078 committed in master by Aravinda VK (avishwan@redhat.com) 
------
commit f41ec4fcfaa9ca976fddbe9e91aabf840c20111f
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Aug 3 17:52:20 2016 +0530

    geo-rep: Use configured log_level for libgfchangelog logs
    
    libgfchangelog was not respecting the log_level configured
    in Geo-replication. With this patch Libgfchangelog log level
    can be configured using `config changelog_log_level TRACE`.
    Default Changelog log level is INFO
    
    BUG: 1363965
    Change-Id: Ida714931129f6a1331b9d0815da77efcb2b898e3
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/15078
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>

Comment 9 Shyamsundar 2017-03-06 17:21:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.