Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363951 - Mouseover on hosted engine "crown" icon, is not showing correct tooltip description.
Summary: Mouseover on hosted engine "crown" icon, is not showing correct tooltip descr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.0.2.3
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.1.0-alpha
: 4.1.0.2
Assignee: Phillip Bailey
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 06:37 UTC by meital avital
Modified: 2017-05-11 09:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The ApplicationConstant used for the original tooltip text used for the tooltip of the hosted engine host icon in the Hosts main tab of the webadmin UI was incorrect. Consequence: The tooltip text displayed for the icon was incorrectly displayed as "action item". Fix: Create a new ApplicationConstant with the correct tooltip text and use it instead of the incorrect one. Result: The tooltip text is displayed correctly as "Running the Hosted Engine VM".
Clone Of:
Environment:
Last Closed: 2017-02-01 14:55:33 UTC
oVirt Team: SLA
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
dfediuck: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
screenshot (deleted)
2016-08-04 06:37 UTC, meital avital
no flags Details
can run he vm.png (deleted)
2016-12-28 13:34 UTC, Nikolai Sednev
no flags Details
running he vm.png (deleted)
2016-12-28 13:35 UTC, Nikolai Sednev
no flags Details
storage crown contains he storage.png (deleted)
2016-12-28 13:35 UTC, Nikolai Sednev
no flags Details
VMs he vm.png (deleted)
2016-12-28 13:36 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 62580 master MERGED webadmin: Correct Tooltip Text for the HE Host Icon 2016-09-06 16:21:37 UTC
oVirt gerrit 65726 ovirt-engine-4.0 POST webadmin: Correct Tooltip Text for the HE Host Icon 2016-10-25 15:37:18 UTC
Red Hat Bugzilla 1308861 None None None Never

Internal Links: 1308861

Description meital avital 2016-08-04 06:37:47 UTC
Created attachment 1187362 [details]
screenshot

Description of problem:
The description of mouseover "crown" icon is not showing correct text.
Currently, it's showing "action item" instead of HE host description.

Version-Release number of selected component (if applicable):
4.0.2.3-0.1.el7ev


How reproducible:
100%

Steps to Reproduce:
1.Have HE deploy
2.In host tab -> mouseover the crown sign -> the note says ' Action Item'

Actual results:
The note is 'Action Item'

Expected results:
The note should indicate that this host is HE VM

Additional info:
See attachment

Comment 1 Doron Fediuck 2016-08-14 07:41:29 UTC
This is the correct behavior.
Status icons are irrelevant for such a description as even HE VM may have different status indications.

Comment 2 Doron Fediuck 2016-08-14 07:43:16 UTC
Please ignore the above comment.
We will look into this although it may be limited by the current UI infra.

Comment 3 Yaniv Lavi 2016-10-26 10:17:48 UTC
Should this be MODIFIED?

Comment 4 Phillip Bailey 2016-10-26 11:21:06 UTC
Yes, moving now.

Comment 5 Sandro Bonazzola 2016-12-12 10:59:31 UTC
This bug is targeted 4.1 but it appears that the fix has been included in ovirt-engine-4.0.6.3. Please crosscheck and re-target if it's fixed in 4.0.6.

Comment 6 Sandro Bonazzola 2016-12-12 13:59:55 UTC
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.

Comment 7 Nikolai Sednev 2016-12-28 13:33:31 UTC
Works for me on these components on hosts:
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
mom-0.5.8-1.el7ev.noarch
ovirt-hosted-engine-setup-2.1.0-0.0.master.20161221071755.git46cacd3.el7.centos.noarch
ovirt-setup-lib-1.1.0-1.el7.centos.noarch
libvirt-client-2.0.0-10.el7_3.2.x86_64
ovirt-release41-pre-4.1.0-0.6.beta2.20161221025826.gitc487776.el7.centos.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
qemu-kvm-rhev-2.6.0-28.el7_3.2.x86_64
ovirt-hosted-engine-ha-2.1.0-0.0.master.20161221070856.20161221070854.git387fa53.el7.centos.noarch
rhevm-appliance-20161116.0-1.el7ev.noarch
sanlock-3.4.0-1.el7.x86_64
ovirt-host-deploy-1.6.0-0.0.master.20161215101008.gitb76ad50.el7.centos.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7ev.noarch
ovirt-imageio-common-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
vdsm-4.18.999-1218.gitd36143e.el7.centos.x86_64
ovirt-imageio-daemon-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
Linux version 3.10.0-514.2.2.el7.x86_64 (mockbuild@x86-019.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Wed Nov 16 13:15:13 EST 2016
Linux 3.10.0-514.2.2.el7.x86_64 #1 SMP Wed Nov 16 13:15:13 EST 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.3 (Maipo)

On engine:
ovirt-engine-setup-plugin-ovirt-engine-common-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-imageio-proxy-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
ovirt-iso-uploader-4.1.0-0.0.master.20160909154152.git14502bd.el7.centos.noarch
ovirt-engine-userportal-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-dbscripts-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-setup-plugin-vmconsole-proxy-helper-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-extensions-api-impl-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-imageio-common-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
ovirt-host-deploy-1.6.0-0.0.master.20161215101008.gitb76ad50.el7.centos.noarch
python-ovirt-engine-sdk4-4.1.0-0.1.a0.20161215git77fce51.el7.centos.x86_64
ovirt-host-deploy-java-1.6.0-0.0.master.20161215101008.gitb76ad50.el7.centos.noarch
ovirt-release41-pre-4.1.0-0.6.beta2.20161221025826.gitc487776.el7.centos.noarch
ovirt-setup-lib-1.1.0-1.el7.centos.noarch
ovirt-engine-extension-aaa-jdbc-1.1.2-1.el7.noarch
ovirt-engine-dwh-setup-4.1.0-0.0.master.20161129154019.el7.centos.noarch
ovirt-imageio-proxy-setup-0.5.0-0.201611201242.gitb02532b.el7.centos.noarch
ovirt-engine-tools-backup-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-websocket-proxy-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-setup-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-backend-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-tools-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-webadmin-portal-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-restapi-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-vmconsole-proxy-helper-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-setup-plugin-ovirt-engine-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-wildfly-overlay-10.0.0-1.el7.noarch
ovirt-engine-cli-3.6.9.2-1.el7.centos.noarch
ovirt-web-ui-0.1.1-2.el7.centos.x86_64
ovirt-engine-setup-base-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-vmconsole-1.0.4-1.el7.centos.noarch
ovirt-engine-dwh-4.1.0-0.0.master.20161129154019.el7.centos.noarch
ovirt-engine-setup-plugin-websocket-proxy-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-hosts-ansible-inventory-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-engine-dashboard-1.1.0-0.4.20161128git5ed6f96.el7.centos.noarch
ovirt-engine-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-guest-agent-common-1.0.13-1.20161220085008.git165fff1.el7.centos.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7.centos.noarch
ovirt-engine-wildfly-10.1.0-1.el7.x86_64
ovirt-engine-lib-4.1.0-0.3.beta2.20161221085908.el7.centos.noarch
ovirt-vmconsole-proxy-1.0.4-1.el7.centos.noarch
Linux version 3.10.0-514.2.2.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Tue Dec 6 23:06:41 UTC 2016
Linux 3.10.0-514.2.2.el7.x86_64 #1 SMP Tue Dec 6 23:06:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
CentOS Linux release 7.3.1611 (Core)

Comment 8 Nikolai Sednev 2016-12-28 13:34:25 UTC
Created attachment 1235634 [details]
can run he vm.png

Comment 9 Nikolai Sednev 2016-12-28 13:35:01 UTC
Created attachment 1235635 [details]
running he vm.png

Comment 10 Nikolai Sednev 2016-12-28 13:35:38 UTC
Created attachment 1235636 [details]
storage crown contains he storage.png

Comment 11 Nikolai Sednev 2016-12-28 13:36:11 UTC
Created attachment 1235637 [details]
VMs he vm.png


Note You need to log in before you can comment on or make changes to this bug.