Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363948 - Spurious failure in tests/bugs/glusterd/bug-1089668.t
Summary: Spurious failure in tests/bugs/glusterd/bug-1089668.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1364326 1364327
TreeView+ depends on / blocked
 
Reported: 2016-08-04 06:23 UTC by Atin Mukherjee
Modified: 2017-03-27 18:17 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1364326 1364327 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:17:28 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2016-08-04 06:23:50 UTC
Description of problem:

Few instances of the failures:

https://build.gluster.org/job/regression-test-burn-in/1447/consoleFull
https://build.gluster.org/job/regression-test-burn-in/1435/consoleFull

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-08-04 06:24:28 UTC
REVIEW: http://review.gluster.org/15085 (tests: fix spurious failure in tests/bugs/glusterd/bug-1089668.t) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Vijay Bellur 2016-08-04 15:44:38 UTC
COMMIT: http://review.gluster.org/15085 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 2650f8b1101a1f345f310475841569feb852bf4b
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Aug 4 11:51:27 2016 +0530

    tests: fix spurious failure in tests/bugs/glusterd/bug-1089668.t
    
    Instead of rebalance stop, its always better to wait for rebalance to complete
    as the former doesn't have any purpose.
    
    Change-Id: Ia1bc2a34d937a0a96543bebd257dcda619f12474
    BUG: 1363948
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/15085
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 3 Shyamsundar 2017-03-27 18:17:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.