Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363944 - [devexp_public_237]Image forcePull policy don't work for runtime image when do extended build
Summary: [devexp_public_237]Image forcePull policy don't work for runtime image when d...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Victor Ionut Palade
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 05:36 UTC by Wang Haoran
Modified: 2016-09-27 09:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:42:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Wang Haoran 2016-08-04 05:36:49 UTC
Description of problem:
Image forcePull policy don't work for runtime image when do extended build

Version-Release number of selected component (if applicable):

openshift v3.3.0.14
kubernetes v1.3.0+57fb9ac
etcd 2.3.0+git
How reproducible:
always

Steps to Reproduce:
1.create a extended build
  oc create -f https://raw.githubusercontent.com/wanghaoran1988/test-for-s2i-extendbuild/master/extended-bc-forcePull.json
  oc start-build extended-build-from-image-forcepull
2.after the build complete, make some change to the runtime image and push back to dockerhub
3.start the build again
4.check whether the builtout image have the changes made in step 2

Actual results:
step 4, image don't have the changes make in step 2, 

Expected results:
we should forcePull the runtime image when set forcePull to true in BuildConfig.

Additional info:

Comment 1 Victor Ionut Palade 2016-08-05 14:37:33 UTC
pull was merged and bug was fixed for this: https://github.com/openshift/origin/pull/10205

Comment 2 Troy Dawson 2016-08-08 21:56:41 UTC
This has been merged and is in OSE v3.3.0.17 or newer.

Comment 4 Wang Haoran 2016-08-09 06:50:42 UTC
verified with 
openshift v3.3.0.17
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

Comment 6 errata-xmlrpc 2016-09-27 09:42:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.