Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363927 - [abrt] webkitgtk4: _g_log_abort(): WebKitWebProcess killed by SIGTRAP
Summary: [abrt] webkitgtk4: _g_log_abort(): WebKitWebProcess killed by SIGTRAP
Keywords:
Status: CLOSED DUPLICATE of bug 1252972
Alias: None
Product: Fedora
Classification: Fedora
Component: webkitgtk4
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Popela
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:e3920fdd030a707710b791f04c3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-04 02:51 UTC by Max
Modified: 2016-11-18 17:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-18 17:39:45 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2016-08-04 02:51 UTC, Max
no flags Details
File: cgroup (deleted)
2016-08-04 02:51 UTC, Max
no flags Details
File: core_backtrace (deleted)
2016-08-04 02:51 UTC, Max
no flags Details
File: dso_list (deleted)
2016-08-04 02:51 UTC, Max
no flags Details
File: environ (deleted)
2016-08-04 02:51 UTC, Max
no flags Details
File: limits (deleted)
2016-08-04 02:51 UTC, Max
no flags Details
File: maps (deleted)
2016-08-04 02:51 UTC, Max
no flags Details
File: mountinfo (deleted)
2016-08-04 02:51 UTC, Max
no flags Details
File: namespaces (deleted)
2016-08-04 02:51 UTC, Max
no flags Details
File: open_fds (deleted)
2016-08-04 02:51 UTC, Max
no flags Details
File: proc_pid_status (deleted)
2016-08-04 02:51 UTC, Max
no flags Details
File: var_log_messages (deleted)
2016-08-04 02:51 UTC, Max
no flags Details

Description Max 2016-08-04 02:51:02 UTC
Description of problem:
I closed Nuvola Player after using it for a while, and the abrt message popped up.

Version-Release number of selected component:
webkitgtk4-2.12.3-1.fc24

Additional info:
reporter:       libreport-2.7.2
backtrace_rating: 4
cmdline:        /usr/libexec/webkit2gtk-4.0/WebKitWebProcess 17
crash_function: _g_log_abort
executable:     /usr/libexec/webkit2gtk-4.0/WebKitWebProcess
global_pid:     24814
kernel:         4.6.4-301.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 _g_log_abort at gmessages.c:325
 #8 XGetGeometry at GetGeom.c:47
 #9 WebCore::GLContextGLX::defaultFrameBufferSize at /usr/src/debug/webkitgtk-2.12.3/Source/WebCore/platform/graphics/glx/GLContextGLX.cpp:189
 #10 WebKit::LayerTreeHostGtk::compositeLayersToContext at /usr/src/debug/webkitgtk-2.12.3/Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:337
 #11 WebKit::LayerTreeHostGtk::flushAndRenderLayers at /usr/src/debug/webkitgtk-2.12.3/Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:370
 #12 WebKit::LayerTreeHostGtk::renderFrame at /usr/src/debug/webkitgtk-2.12.3/Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:309
 #13 std::function<bool ()>::operator()() const at /usr/include/c++/6.1.1/functional:2136
 #14 WebKit::LayerTreeHostGtk::RenderFrameScheduler::renderFrame at /usr/src/debug/webkitgtk-2.12.3/Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:124
 #15 WTF::RunLoop::TimerBase::<lambda(gpointer)>::operator() at /usr/src/debug/webkitgtk-2.12.3/Source/WTF/wtf/glib/RunLoopGLib.cpp:131
 #16 WTF::RunLoop::TimerBase::<lambda(gpointer)>::_FUN(gpointer) at /usr/src/debug/webkitgtk-2.12.3/Source/WTF/wtf/glib/RunLoopGLib.cpp:135

Potential duplicate: bug 1252972

Comment 1 Max 2016-08-04 02:51:07 UTC
Created attachment 1187318 [details]
File: backtrace

Comment 2 Max 2016-08-04 02:51:08 UTC
Created attachment 1187319 [details]
File: cgroup

Comment 3 Max 2016-08-04 02:51:09 UTC
Created attachment 1187320 [details]
File: core_backtrace

Comment 4 Max 2016-08-04 02:51:09 UTC
Created attachment 1187321 [details]
File: dso_list

Comment 5 Max 2016-08-04 02:51:10 UTC
Created attachment 1187322 [details]
File: environ

Comment 6 Max 2016-08-04 02:51:11 UTC
Created attachment 1187323 [details]
File: limits

Comment 7 Max 2016-08-04 02:51:12 UTC
Created attachment 1187324 [details]
File: maps

Comment 8 Max 2016-08-04 02:51:13 UTC
Created attachment 1187325 [details]
File: mountinfo

Comment 9 Max 2016-08-04 02:51:13 UTC
Created attachment 1187326 [details]
File: namespaces

Comment 10 Max 2016-08-04 02:51:14 UTC
Created attachment 1187327 [details]
File: open_fds

Comment 11 Max 2016-08-04 02:51:15 UTC
Created attachment 1187328 [details]
File: proc_pid_status

Comment 12 Max 2016-08-04 02:51:16 UTC
Created attachment 1187329 [details]
File: var_log_messages

Comment 13 Michael Catanzaro 2016-11-18 17:39:45 UTC

*** This bug has been marked as a duplicate of bug 1252972 ***


Note You need to log in before you can comment on or make changes to this bug.