Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363884 - The tomcat-tool-wrapper script is broken
Summary: The tomcat-tool-wrapper script is broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tomcat
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Coty Sutherland
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1363887 1364067
TreeView+ depends on / blocked
 
Reported: 2016-08-03 20:08 UTC by Coty Sutherland
Modified: 2016-09-01 18:54 UTC (History)
7 users (show)

Fixed In Version: tomcat-8.0.36-2.fc25 tomcat-8.0.36-2.fc24 tomcat-8.0.36-2.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1363887 (view as bug list)
Environment:
Last Closed: 2016-09-01 13:38:39 UTC


Attachments (Terms of Use)

Description Coty Sutherland 2016-08-03 20:08:24 UTC
Description of problem:
The tomcat-tool-wrapper provided by the tomcat package doesn't work.

Version-Release number of selected component (if applicable):
tomcat-8.0.32-5.fc23.noarch

How reproducible:
Every time.

Steps to Reproduce:
1. Install tomcat via `yum install tomcat`
2. Execute the command and observe:

[coty@localhost tomcat]$ tomcat-tool-wrapper -server org.apache.catalina.realm.RealmBase -a md5 test
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tomcat/util/ExceptionUtils
	at org.apache.catalina.startup.Tool.main(Tool.java:218)
Caused by: java.lang.ClassNotFoundException: org.apache.tomcat.util.ExceptionUtils
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 1 more
ABRT problem creation: 'success'

Actual results:
A CNFE is thrown because the ExceptionUtils class is not in the classpath.

Expected results:
[coty@localhost tomcat]$ tomcat-tool-wrapper -server org.apache.catalina.realm.RealmBase -a md5 test
test:4af3bd7759edac2bd372d04c343aee12f789394ecada8c9ce6fc32555fbf5c76$1$58040d6efb505a5e2bcf7c863968a192

Additional info:

Comment 1 Coty Sutherland 2016-08-03 20:14:42 UTC
https://github.com/csutherl/fedora-tomcat/commit/03bdca3

I have an additional question regarding the wrapper script. Is there a reason why we've generated our own instead of using what's provided with tomcat?

Comment 3 Fedora Update System 2016-08-11 18:50:19 UTC
tomcat-8.0.36-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a4dccdd23

Comment 4 Fedora Update System 2016-08-11 18:51:02 UTC
tomcat-8.0.36-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2b0c16fd82

Comment 5 Fedora Update System 2016-08-11 18:51:43 UTC
tomcat-8.0.36-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f4a443888b

Comment 6 Fedora Update System 2016-08-12 14:28:30 UTC
tomcat-8.0.36-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f4a443888b

Comment 7 Fedora Update System 2016-08-12 20:53:16 UTC
tomcat-8.0.36-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a4dccdd23

Comment 8 Fedora Update System 2016-08-12 20:53:19 UTC
tomcat-8.0.36-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2b0c16fd82

Comment 9 Fedora Update System 2016-09-01 13:37:23 UTC
tomcat-8.0.36-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-09-01 16:55:58 UTC
tomcat-8.0.36-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-09-01 18:53:26 UTC
tomcat-8.0.36-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.