Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363882 - Text dialog updates fire too many events causing delays
Summary: Text dialog updates fire too many events causing delays
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Martin Hradil
QA Contact: Shveta
URL:
Whiteboard: dialog
Depends On:
Blocks: 1372767
TreeView+ depends on / blocked
 
Reported: 2016-08-03 19:43 UTC by Colin Arnott
Modified: 2017-01-04 12:58 UTC (History)
6 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1372767 (view as bug list)
Environment:
Last Closed: 2017-01-04 12:58:59 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0012 normal SHIPPED_LIVE CFME 5.7.0 bug fixes and enhancement update 2017-01-04 17:50:36 UTC

Description Colin Arnott 2016-08-03 19:43:21 UTC
Description of problem:
As a user when I enter text into fields in a service dialogue many POST update events are fired causing extensive delays in the value actually being updated for the dialogue.

When I select all of the text and press delete there are also many events sent.

Version-Release number of selected component (if applicable):
cfme-5.6.0.13

Steps to Reproduce:
Any time the user clicks the button for the dynamic dialog prior to all of the update events being sent and processed by MIQ. For a proficient typist this happens most of the time.

Additional info:
I am including a video showing the extensive delay seen and the many POST update events sent

Comment 7 Shveta 2016-09-21 04:30:32 UTC
Fixed.Verified in 5.7.0.0.20160906172503_12f65cb

Comment 10 errata-xmlrpc 2017-01-04 12:58:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html


Note You need to log in before you can comment on or make changes to this bug.