Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363880 - VMware folder support showing more than just folders
Summary: VMware folder support showing more than just folders
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Lucy Fu
QA Contact: Alex Newman
URL:
Whiteboard: vmware
: 1385481 (view as bug list)
Depends On:
Blocks: 1370569
TreeView+ depends on / blocked
 
Reported: 2016-08-03 19:30 UTC by Colin Arnott
Modified: 2018-01-19 21:24 UTC (History)
9 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1370569 (view as bug list)
Environment:
Last Closed: 2017-01-11 20:13:05 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Colin Arnott 2016-08-03 19:30:02 UTC
Description of problem:
When selecting a vcenter folder from CF it displays more then just the Vcenter folders. Datastores and host is also available. I'm assuming this wasn't by design?

Version-Release number of selected component (if applicable):
vmware-5.5
cfme-5.6.0.13

How reproducible:
trivial

Steps to Reproduce:
1. add VMware provider
2. finish ems refresh
3. provision new VM
4. view placement folders drop down 

Actual results:
(attached cfme_screenshot.png)

Expected results:
(attached vmware_screenshot.png)

Additional info:
(screenshots pending)

Comment 4 Greg McCullough 2016-08-03 20:37:23 UTC
Drew - I would suggest working with Adam on this one.  It looks like we are collecting VMware folder types (host/datastore) that we were not collecting before.  They are now showing up in the folder selection in the VMware provisioning UI.  Maybe there is a different call we should be making to only get VM folders back.

Comment 6 CFME Bot 2016-08-15 23:00:54 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/d80ef718174b98c5150347ec9705190c27f69ad9

commit d80ef718174b98c5150347ec9705190c27f69ad9
Author:     Lucy Fu <lufu@redhat.com>
AuthorDate: Mon Aug 15 17:09:09 2016 -0400
Commit:     Lucy Fu <lufu@redhat.com>
CommitDate: Mon Aug 15 17:10:47 2016 -0400

    Add the hidden column into EmsFolder's MiqHasStruct.
    
    Commit 7eec1c677 has changed the way to use the hidden column to determine if a ems_folder should be displayed to the user or not.
    However, the hidden column got lost when an EmsFolder object is  converted to a MiqHashStruct.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1363880

 app/models/miq_request_workflow.rb       |  4 ++--
 spec/models/miq_request_workflow_spec.rb | 11 +++++++++++
 2 files changed, 13 insertions(+), 2 deletions(-)

Comment 9 Alex Newman 2016-10-06 16:56:54 UTC
5.7.0.3

Comment 10 Greg McCullough 2016-10-17 12:50:21 UTC
*** Bug 1385481 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.