Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363843 - [RFE] remote-viewer should have one display in FS mode for client with many monitors in mirror mode
Summary: [RFE] remote-viewer should have one display in FS mode for client with many m...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Virt Viewer Maint
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 17:30 UTC by Andrei Stepanov
Modified: 2017-04-06 14:12 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-06 14:12:18 UTC


Attachments (Terms of Use)
remote-viewer log (deleted)
2016-08-03 17:33 UTC, Andrei Stepanov
no flags Details
screenshot (deleted)
2016-08-03 17:36 UTC, Andrei Stepanov
no flags Details

Description Andrei Stepanov 2016-08-03 17:30:19 UTC
remote-viewer always starts with a number of display == number of active monitors on client.

virt-viewer-2.0-11.el7.x86_64

Always reproducible.

1. Client should have two physical monitors.
2. In Gnome open Settings->Displays
3. Select second monitor, and make it "Mirror".
4. Go to RHEVM user-portal.
5. Select VM and change console options to connect in fullscreen mode.
6. Connect to the VM.
 
Actual results: remote viewer starts with two displays.
Expected results: should be on display.

Comment 1 Andrei Stepanov 2016-08-03 17:33:51 UTC
Created attachment 1187149 [details]
remote-viewer log

Comment 2 Andrei Stepanov 2016-08-03 17:36:54 UTC
Created attachment 1187151 [details]
screenshot

Comment 3 Pavel Grunt 2017-02-09 14:09:00 UTC
It will require some cooperation with the desktop env (to know that monitors are in mirror mode). Also can be very desktop specific (eg: may work on Linux a but not on a Windows client) - we definitely want a robust solution.

Comment 4 Pavel Grunt 2017-03-17 15:14:01 UTC
It basically doing what is requested to do:
(remote-viewer:15442): GSpice-DEBUG: channel-main.c:1164 main-1:0: sending new monitors config to guest
(remote-viewer:15442): GSpice-DEBUG: channel-main.c:1181 main-1:0: monitor #0: 1280x1024+0+0 @ 32 bpp
(remote-viewer:15442): GSpice-DEBUG: channel-main.c:1181 main-1:0: monitor #1: 1280x1024+0+0 @ 32 bpp

it asks guest to have 2 monitors in mirror mode. And the guest indeed creates them accordingly

(remote-viewer:15442): GSpice-DEBUG: channel-display.c:1855 display-2:0: received new monitors config from guest: n: 2/4
(remote-viewer:15442): GSpice-DEBUG: channel-display.c:1875 display-2:0: monitor id: 0, surface id: 0, +0+0-1280x1024
(remote-viewer:15442): GSpice-DEBUG: channel-display.c:1875 display-2:0: monitor id: 1, surface id: 0, +0+0-1280x1024


I am not sure whether it is useful to try to implement this feature.
What about situation when user disables the mirroring ? Should it open new windows? How it should behave when there are some monitors in the mirror mode and some not?
What is the real goal of the RFE ? What issue we are trying to solve ?

Jonathon: NOTABUG ?

Comment 5 Daniel Berrange 2017-03-17 15:18:07 UTC
This looks like NOTABUG to me. If the card has 2 heads, and the guest is configured in mirror mode, this does *not* mean remote-viewer should only have 1 window open.  mirror mode explicitly means the user wants 2 outputs with the same content. If they only want one remote-viewer window open, then they should disable the second head, not mirror it.

Comment 6 Jonathon Jongsma 2017-03-31 21:47:59 UTC
It seems like there may be some confusion here. I think this bug is related to a client configured in mirror mode, not a guest configured in mirror mode.

I do think that if the client machine is configured with two monitors in mirror mode, it's slightly odd to open two fullscreen displays that will both be displayed on each monitor (albeit only one will be visible since they'll be stacked on top of eachother). On the other hand, if those guest displays are both displaying the same thing (as Pavel's debug log above indicates), the fact that you can only see one of those displays doesn't matter too much.

So I do think that this is a bug, but the impact is quite small (a second fullscreen window with the exact same content hidden behind another fullscreen window). In addition, as Pavel mentioned above, a solution would be pretty desktop-specific and may be tricky to implement on each platform. Since this is the first time this issue has been reported, I suspect that it's quite uncommon for people to use mirrored-mode client machines to launch full-screen virt-viewer. Combined with the fact that the impact of the bug is so small, maybe it's not worth risking potential regressions to fix this case?

Comment 7 Pavel Grunt 2017-04-06 14:12:18 UTC
Closing per comments 4 & 5. Also workarounds exist (monitor mapping, settings expected number of heads...)

Feel free to reopen answering questions raised in the comments


Note You need to log in before you can comment on or make changes to this bug.