Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363830 - friendly-name change no non-friendly-name failed after set user_friendly_names from yes to no
Summary: friendly-name change no non-friendly-name failed after set user_friendly_name...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Zhang Yi
Steven J. Levine
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 16:46 UTC by Zhang Yi
Modified: 2016-11-04 08:20 UTC (History)
5 users (show)

Fixed In Version: device-mapper-multipath-0.4.9-96.el7
Doc Type: Bug Fix
Doc Text:
Multipath no longer occasionally fails while renaming devices Previously, multipath was using an uninitialized variable in the function to rename a device. This would cause multipath to fail occasionally while renaming a device because the variable was set to an invalid value. With this fix, multipath now initializes this variable when renaming a device.
Clone Of:
Environment:
Last Closed: 2016-11-04 08:20:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2536 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2016-11-03 14:18:10 UTC

Comment 3 Ben Marzinski 2016-08-05 21:42:02 UTC
This (and possibly Bug 1363937) are caused by an uninitialized variable being passed by dm_rename. I have a fix for it.

Comment 7 errata-xmlrpc 2016-11-04 08:20:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2536.html


Note You need to log in before you can comment on or make changes to this bug.